summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6252f93e106..a7f28a938d9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-flask-cache
pkgdesc = Adds cache support to your Flask application
pkgver = 0.13.1
- pkgrel = 1
+ pkgrel = 2
url = http://pypi.python.org/pypi/Flask-Cache
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 751e93373cf5..81a4eae66a80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Justin Dray <justin@dray.be>
+# Maintainer: Christian Mauderer <oss@c-mauderer.de>
+# Previous maintainer: Justin Dray <justin@dray.be>
pkgname='python-flask-cache'
pkgver=0.13.1
-pkgrel=1
+pkgrel=2
pkgdesc='Adds cache support to your Flask application'
arch=('any')
url='http://pypi.python.org/pypi/Flask-Cache'
@@ -16,6 +17,10 @@ conflicts=('python-flask-cache-git')
build() {
cd "${srcdir}/Flask-Cache-${pkgver}"
+
+ # Workaround for https://github.com/thadeusb/flask-cache/issues/188
+ sed -e 's/flask.ext.cache/flask_cache/g' -i flask_cache/jinja2ext.py
+
python ./setup.py build
}