summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3fad988f1d83
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Apr 13 10:43:56 UTC 2016
+pkgbase = python-flup-hg
+ pkgdesc = Random Python WSGI stuff
+ pkgver = 141+.916cde7b7d57+
+ pkgrel = 1
+ url = http://www.saddi.com/software/flup/
+ arch = any
+ license = BSD
+ makedepends = mercurial
+ makedepends = python-distribute
+ depends = python
+ provides = python-flup
+ conflicts = python-flup
+ source = hg+http://hg.saddi.com/flup-py3.0
+ sha1sums = SKIP
+
+pkgname = python-flup-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0cd688532659
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Nils Czernia <nils@czserver.de>
+# Based on AUR3 paket from Florian Bruhin (The Compiler) <archlinux.org@the-compiler.org>
+
+pkgname=python-flup-hg
+_hgrepo='flup-py3.0'
+pkgver=141+.916cde7b7d57+
+pkgrel=1
+pkgdesc="Random Python WSGI stuff"
+arch=(any)
+url="http://www.saddi.com/software/flup/"
+license=('BSD')
+depends=('python')
+makedepends=('mercurial' 'python-distribute')
+provides=('python-flup')
+conflicts=('python-flup')
+source=('hg+http://hg.saddi.com/flup-py3.0')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$_hgrepo"
+ echo $(hg identify -n).$(hg identify -i)
+}
+
+prepare() {
+ cd "$_hgrepo"
+
+ # [HACKY] thread got renamed to _thread
+ sed -i -e 's/^import thread$/import _thread/' \
+ -e 's/ thread\./ _thread./g' \
+ "flup/server/threadpool.py"
+}
+
+package() {
+ cd "$_hgrepo"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: