summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6c42272dd65..d02b856dd31b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-fontmath-git
pkgdesc = A collection of objects that implement fast font, glyph, etc. math.
- pkgver = 0.9.3.r2.g777dd88
+ pkgver = 0.9.3.r4.g8325a8f
pkgrel = 1
url = https://github.com/robotools/fontMath
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index e13c3b3c5207..6eda091e76d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: taotieren <admin@taotieren.com>
pkgname=python-fontmath-git
-pkgver=0.9.3.r2.g777dd88
+pkgver=0.9.3.r4.g8325a8f
pkgrel=1
pkgdesc='A collection of objects that implement fast font, glyph, etc. math.'
url='https://github.com/robotools/fontMath'
@@ -23,6 +23,11 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare()
+{
+ git -C "${srcdir}/${pkgname}" clean -dfx
+}
+
build() {
cd "$pkgname"
python -m build -wn