summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d2435da038c..8b56f2948635 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,10 @@ pkgbase = python-fortranformat
url = https://github.com/brendanarnold/py-fortranformat
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python
source = https://pypi.org/packages/source/f/fortranformat/fortranformat-2.0.0.tar.gz
sha512sums = 948473cdd38b755bf06293301d44f42566b0be8a0b213fa5272a867994c85482abfd712762ee3e59b12899e6eaba6aa6ae6d022dc000638e67b9d0cbdf23678b
diff --git a/PKGBUILD b/PKGBUILD
index 9f1c7e409bb0..1a19c8647889 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,17 +9,17 @@ arch=(any)
url="https://github.com/brendanarnold/py-${_base}"
license=(MIT)
depends=(python)
-makedepends=(python-setuptools)
+makedepends=(python-build python-installer python-setuptools python-wheel)
source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
sha512sums=('948473cdd38b755bf06293301d44f42566b0be8a0b213fa5272a867994c85482abfd712762ee3e59b12899e6eaba6aa6ae6d022dc000638e67b9d0cbdf23678b')
build() {
cd ${_base}-${pkgver}
- python setup.py build
+ python -m build --wheel --skip-dependency-check --no-isolation
}
package() {
cd ${_base}-${pkgver}
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}