summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
-rw-r--r--READMEPYPI.md9
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e72fbb68c6b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-gdf-formatter
+ pkgdesc = A simple and flexible Python library to create and format your graphs in GDF format.
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/GabrielTrettel/GDF_Formatter
+ arch = any
+ license = MPL
+ makedepends = python-setuptools
+ depends = python>=3
+ source = https://github.com/GabrielTrettel/GDF_Formatter/archive/v.1.0.1.tar.gz
+ source = READMEPYPI.md
+ sha256sums = 4118cf662a3462120b26220838290ed98ee5686c0aae0ce11ab611aca7a037ba
+ sha256sums = e22e54d86f432183e49148c34774644d347e4a2052b8ba6a9f3d447f05e1ac8c
+
+pkgname = python-gdf-formatter
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f82c02f047b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: GrayJack <gr41.j4ck@gmail.com>
+
+pkgname="python-gdf-formatter"
+pkgver=1.0.1
+pkgrel=1
+pkgdesc='A simple and flexible Python library to create and format your graphs in GDF format.'
+arch=('any')
+url='https://github.com/GabrielTrettel/GDF_Formatter'
+license=('MPL')
+depends=('python>=3')
+makedepends=('python-setuptools')
+source=("${url}/archive/v.${pkgver}.tar.gz"
+ "READMEPYPI.md")
+sha256sums=('4118cf662a3462120b26220838290ed98ee5686c0aae0ce11ab611aca7a037ba'
+ 'e22e54d86f432183e49148c34774644d347e4a2052b8ba6a9f3d447f05e1ac8c')
+
+build() {
+ cp READMEPYPI.md GDF_Formatter-v.${pkgver}
+ cd GDF_Formatter-v.${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd GDF_Formatter-v.${pkgver}
+ python setup.py install --root="$pkgdir" --optimize=1
+
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/READMEPYPI.md b/READMEPYPI.md
new file mode 100644
index 000000000000..ad862a3df134
--- /dev/null
+++ b/READMEPYPI.md
@@ -0,0 +1,9 @@
+This is a simple and flexible Python library to create and format your graphs in GDF.
+
+For simple usage tutorial, follow https://github.com/GabrielTrettel/GDF_Formatter
+
+Creators:
+
+Gabriel M. Trettel, https://github.com/GabrielTrettel
+
+GrayJack, https://github.com/GrayJack