summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD30
2 files changed, 19 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b0febe25aa1..6f7c8acac69c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = python-gffutils
pkgdesc = GFF and GTF file manipulation and interconversion in Python
- pkgver = 0.10.1
+ pkgver = 0.11.1
pkgrel = 1
url = https://github.com/daler/gffutils
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python-argcomplete
depends = python-argh
depends = python-pyfaidx
@@ -14,9 +17,9 @@ pkgbase = python-gffutils
optdepends = bedtools: for genomic interval arithemtic
optdepends = python-biopython: for sequence manipulation
optdepends = python-pybedtools: wrapper for bedtools
- source = python-gffutils-0.10.1.tar.gz::https://github.com/daler/gffutils/archive/v0.10.1.tar.gz
+ source = python-gffutils-0.11.1.tar.gz::https://files.pythonhosted.org/packages/source/g/gffutils/gffutils-0.11.1.tar.gz
source = 001-setup.py.patch
- sha256sums = c020f38d572a38227d575ca6b4a6781e10317c4231c7008f533bb6d9167f64d8
+ sha256sums = ca7bf814d600b389bb2d5c403dd279755118cb1476c19c6f7aecb8c51a84263c
sha256sums = 8b8b8e89a6cf1cd74f73f5e5a67053a24bcc681182bc20c30716818fe9243c58
pkgname = python-gffutils
diff --git a/PKGBUILD b/PKGBUILD
index 5c0c53a31828..e3241cddeba7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,40 +2,36 @@
# Contributor: Clint Valentine <valentine.clint@gmail.com>
pkgname=python-gffutils
-pkgver=0.10.1
+_pkg="${pkgname#python-}"
+pkgver=0.11.1
pkgrel=1
pkgdesc="GFF and GTF file manipulation and interconversion in Python"
arch=('any')
url="https://github.com/daler/gffutils"
license=('MIT')
-depends=(
- 'python-argcomplete'
- 'python-argh'
- 'python-pyfaidx'
- 'python-simplejson'
- 'python-six')
+depends=('python-argcomplete' 'python-argh' 'python-pyfaidx' 'python-simplejson' 'python-six')
optdepends=(
'bedtools: for genomic interval arithemtic'
'python-biopython: for sequence manipulation'
'python-pybedtools: wrapper for bedtools')
-makedepends=('python-setuptools')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/g/$_pkg/$_pkg-$pkgver.tar.gz"
'001-setup.py.patch')
-sha256sums=('c020f38d572a38227d575ca6b4a6781e10317c4231c7008f533bb6d9167f64d8'
+sha256sums=('ca7bf814d600b389bb2d5c403dd279755118cb1476c19c6f7aecb8c51a84263c'
'8b8b8e89a6cf1cd74f73f5e5a67053a24bcc681182bc20c30716818fe9243c58')
prepare() {
- patch -p1 -d "gffutils-$pkgver" < 001-setup.py.patch
- sed -i "s/@PKGVER@/$pkgver/" "gffutils-$pkgver/setup.py"
+ patch -p1 -d "$_pkg-$pkgver" < 001-setup.py.patch
+ sed -i "s/@PKGVER@/$pkgver/" "$_pkg-$pkgver/setup.py"
}
build(){
- cd "gffutils-$pkgver"
- python setup.py build
+ cd "$_pkg-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- cd "gffutils-$pkgver"
- PYTHONHASHSEED=0 python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ cd "$_pkg-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dvm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}