summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5151e1ddddff..b2cdc616b67b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = python-google
pkgdesc = Google search from Python
pkgver = 3.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/MarioVilas/googlesearch
- arch = x86_64
- license = BSD-3-Clause
- makedepends = python
+ arch = any
+ license = BSD
makedepends = python-setuptools
- depends = python
depends = python-beautifulsoup4
- source = python-google-3.0.0::https://github.com/MarioVilas/googlesearch/archive/v3.0.0.tar.gz
+ source = python-google-3.0.0.tar.gz::https://github.com/MarioVilas/googlesearch/archive/v3.0.0.tar.gz
sha256sums = 9fd814876322b84f7f73499f3bd96b4da7533904e7f00c6dea2e262a467889d1
pkgname = python-google
diff --git a/PKGBUILD b/PKGBUILD
index 26e7f95cfc56..724de1d409c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,14 @@
pkgname=python-google
pkgver=3.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='Google search from Python'
-arch=('x86_64')
+arch=('any')
url='https://github.com/MarioVilas/googlesearch'
-license=('BSD-3-Clause')
-depends=(python python-beautifulsoup4)
-optdepends=()
-makedepends=(python python-setuptools)
-source=("$pkgname-$pkgver::https://github.com/MarioVilas/googlesearch/archive/v$pkgver.tar.gz")
+license=('BSD')
+depends=(python-beautifulsoup4)
+makedepends=(python-setuptools)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/MarioVilas/googlesearch/archive/v$pkgver.tar.gz")
sha256sums=('9fd814876322b84f7f73499f3bd96b4da7533904e7f00c6dea2e262a467889d1')
_pkgname=googlesearch
@@ -23,4 +22,6 @@ build() {
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py install --root="$pkgdir"/ --optimize=1
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
+# vim:set ts=2 sw=2 et: