summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45da802b2334..3bde5cd494d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,7 @@ pkgbase = python-gpy
license = BSD
makedepends = python-setuptools
makedepends = python-numpy
+ makedepends = cython
depends = python
depends = python-numpy
depends = python-scipy
diff --git a/PKGBUILD b/PKGBUILD
index 55c1609fcbb3..b0760173bf27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,14 +10,14 @@ license=("BSD")
url="https://github.com/SheffieldML/GPy"
depends=('python' 'python-numpy' 'python-scipy' 'python-six' 'python-paramz' 'python-matplotlib' 'python-climin-git')
optdepends=('python-plotly' 'ipython' 'python-sphinx' 'python-ipykernel' 'python-ipywidgets' 'python-jupyter_client' 'jupyter-notebook' 'python-mpi4py')
-makedepends=('python-setuptools' 'python-numpy')
+makedepends=('python-setuptools' 'python-numpy' 'cython')
source=("https://github.com/SheffieldML/GPy/archive/v${pkgver}.tar.gz")
sha512sums=("50dc3627a05b9fc2fbc61204cf492e89d5c067da7aca3e738c52cc3c06652aa825e27e66b0a14a2e67e074cd19a75ab564449a762f1de1ba27a02fc986432403")
prepare() {
cd "GPy-${pkgver}"
- # Forcibly update cython for python 3.7
+ # Forcibly update cython for python 3.7 (https://github.com/SheffieldML/GPy/issues/649)
find . -name '*.pyx' -exec cython {} \;
}