summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--cython-v1.9.5.patch37
3 files changed, 7 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d3f90ad0b61..af09608fa3e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-gpy
pkgdesc = Gaussian processes framework in python
- pkgver = 1.9.5
+ pkgver = 1.9.6
pkgrel = 1
url = https://github.com/SheffieldML/GPy
arch = any
@@ -23,10 +23,8 @@ pkgbase = python-gpy
optdepends = python-jupyter_client
optdepends = jupyter-notebook
optdepends = python-mpi4py
- source = https://github.com/SheffieldML/GPy/archive/v1.9.5.tar.gz
- source = cython-v1.9.5.patch
- sha512sums = e4d45b426977ef1d987ffde9275adeeac3eb85874cee4049f40a255c14a54ebcfb7e1c402046af6818e20a7b166e51162731d3d904f2e43e830519c6c9489ae2
- sha512sums = 1c173cdac44e13663a6320528fa4a772c17adb37039dbda34633f1d4912ea5c3192cc7b13ac61bc036e06c538e5b5b63201b3a72ca7ebc37234dd2643e62ac0e
+ source = https://files.pythonhosted.org/packages/source/G/GPy/GPy-1.9.6.tar.gz
+ sha256sums = f11d649b3320d4cb836d283706754953277c8696977726803ccd3ee1355a94a7
pkgname = python-gpy
diff --git a/PKGBUILD b/PKGBUILD
index 454c17e9d5dd..9a61e1b61339 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
# Contributor:
pkgname=python-gpy
-pkgver=1.9.5
+_name=GPy
+pkgver=1.9.6
pkgrel=1
pkgdesc="Gaussian processes framework in python"
arch=("any")
@@ -11,15 +12,10 @@ url="https://github.com/SheffieldML/GPy"
depends=('python' 'python-numpy' 'python-scipy' 'python-six' 'python-paramz' 'python-matplotlib' 'python-climin-git')
optdepends=('python-plotly' 'ipython' 'python-sphinx' 'python-ipykernel' 'python-ipywidgets' 'python-jupyter_client' 'jupyter-notebook' 'python-mpi4py')
makedepends=('python-setuptools' 'python-numpy' 'cython')
-source=("https://github.com/SheffieldML/GPy/archive/v${pkgver}.tar.gz"
- "cython-v1.9.5.patch")
-sha512sums=("e4d45b426977ef1d987ffde9275adeeac3eb85874cee4049f40a255c14a54ebcfb7e1c402046af6818e20a7b166e51162731d3d904f2e43e830519c6c9489ae2"
- "1c173cdac44e13663a6320528fa4a772c17adb37039dbda34633f1d4912ea5c3192cc7b13ac61bc036e06c538e5b5b63201b3a72ca7ebc37234dd2643e62ac0e")
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=("f11d649b3320d4cb836d283706754953277c8696977726803ccd3ee1355a94a7")
prepare() {
- # Fix Cython compilation errors (https://github.com/SheffieldML/GPy/pull/677)
- patch -p1 -i cython-v1.9.5.patch
-
cd "GPy-${pkgver}"
# Forcibly update cython for python 3.7 (https://github.com/SheffieldML/GPy/issues/649)
diff --git a/cython-v1.9.5.patch b/cython-v1.9.5.patch
deleted file mode 100644
index 2693eedcf9d4..000000000000
--- a/cython-v1.9.5.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-diff -ura src/GPy-1.9.5/GPy/models/state_space_cython.pyx src/GPy-1.9.5/GPy/models/state_space_cython.pyx
---- src/GPy-1.9.5/GPy/models/state_space_cython.pyx 2018-09-02 23:50:17.000000000 +0200
-+++ src/GPy-1.9.5/GPy/models/state_space_cython.pyx 2018-09-16 16:16:08.000000000 +0200
-@@ -484,7 +484,7 @@
- if matrix_index in self.Q_square_root_dict:
- square_root = self.Q_square_root_dict[matrix_index]
- else:
-- if matrix_index not in self.Q_svd_dict
-+ if matrix_index not in self.Q_svd_dict:
- U,S,Vh = sp.linalg.svd( self.Qs[:,:, matrix_index],
- full_matrices=False, compute_uv=True,
- overwrite_a=False, check_finite=False)
-@@ -514,7 +514,7 @@
- if matrix_index in self.Q_inverse_dict:
- Q_inverse = self.Q_inverse_dict[matrix_index]
- else:
-- if matrix_index not in self.Q_svd_dict
-+ if matrix_index not in self.Q_svd_dict:
- U,S,Vh = sp.linalg.svd( self.Qs[:,:, matrix_index],
- full_matrices=False, compute_uv=True,
- overwrite_a=False, check_finite=False)
-@@ -522,7 +522,7 @@
- else:
- U,S,Vh = self.Q_svd_dict[matrix_index]
-
-- Q_inverse = Q_inverse = np.dot( Vh.T * ( 1.0/(S + jitter)) , U.T )
-+ Q_inverse = Q_inverse = np.dot( Vh.T * ( 1.0/(S + jitter)) , U.T )
- self.Q_inverse_dict[matrix_index] = Q_inverse
-
- return Q_inverse
-@@ -998,4 +998,4 @@
- M[k+1,:,:] = m_upd # separate mean value for each time series
- P[k+1,:,:] = P_upd[0]
-
-- return (M, P, log_likelihood, grad_log_likelihood, p_dynamic_callables.reset(False))
-\ No newline at end of file
-+ return (M, P, log_likelihood, grad_log_likelihood, p_dynamic_callables.reset(False))