summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD12
2 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3cbb09e79e04..ee5ebbbc1061 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
-pkgbase = python-httpx
- pkgdesc = A next generation HTTP client for Python
+pkgbase = python-httpx0.13
+ pkgdesc = A next generation HTTP client for Python (version 0.13)
pkgver = 0.13.3
- pkgrel = 5
+ pkgrel = 1
url = https://github.com/encode/httpx
arch = any
license = BSD
@@ -13,16 +13,18 @@ pkgbase = python-httpx
makedepends = python-setuptools
depends = python-chardet
depends = python-hstspreload
- depends = python-httpcore
+ depends = python-httpcore<0.11
depends = python-idna
depends = python-rfc3986
depends = python-sniffio
optdepends = python-brotli: for brotli response decompression
- source = python-httpx-0.13.3.tar.gz::https://github.com/encode/httpx/archive/0.13.3.tar.gz
+ provides = python-httpx=0.13.3
+ conflicts = python-httpx
+ source = python-httpx0.13-0.13.3.tar.gz::https://github.com/encode/httpx/archive/0.13.3.tar.gz
source = 0001-Do-not-override-the-system-SSL-certificates-with-the.patch
sha512sums = 54cdee16e8253c221c3298817ccf63a4a0d6755a86feea2aa5a2efe9af44eb1eb0a578b21f593fe28fceace17b0a0badb52a66965c35bf456ea57dd3b905ebbe
sha512sums = 9affdf1c41fc9660b0374d2adae8115aa01e31fa13d396a682593ff24248bf4b70fa1266d01a95281fab760265292c0d97f329f71b00e723ad71ae809c4e6235
b2sums = d3a56c2386841909668e34eaa78d202f91ad900230b9d1d4254bfa08312312d020e081aea2839dbb57d85fa26ccfc3f093404801c4dd5c47051f3c9fd2746552
b2sums = b96027d611901e65f90969f796c244acb8605243e2fd23eb2ea946b895464e6e89a39c9886de479f8561a4d55154e2a80dc21f6f29c201a36f7ca429c6962f9f
-pkgname = python-httpx
+pkgname = python-httpx0.13
diff --git a/PKGBUILD b/PKGBUILD
index ea13cb109b67..f46494dc09a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
-# Maintainer: Eli Schwartz <eschwartz@archlinux.org>
+# Contributor: Eli Schwartz <eschwartz@archlinux.org>
_pkgname=httpx
-pkgname=python-httpx
+pkgname=python-httpx0.13
pkgver=0.13.3
-pkgrel=5
-pkgdesc="A next generation HTTP client for Python"
+pkgrel=1
+pkgdesc="A next generation HTTP client for Python (version 0.13)"
arch=('any')
url="https://github.com/encode/${_pkgname}"
license=('BSD')
-depends=('python-chardet' 'python-hstspreload' 'python-httpcore' 'python-idna' 'python-rfc3986' 'python-sniffio')
+depends=('python-chardet' 'python-hstspreload' 'python-httpcore<0.11' 'python-idna' 'python-rfc3986' 'python-sniffio')
optdepends=('python-brotli: for brotli response decompression')
makedepends=('python-setuptools')
checkdepends=('python-pytest-asyncio' 'python-pytest-trio' 'python-brotli' 'python-trustme' 'uvicorn')
+provides=("python-httpx=${pkgver}")
+conflicts=('python-httpx')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz"
"0001-Do-not-override-the-system-SSL-certificates-with-the.patch")
sha512sums=('54cdee16e8253c221c3298817ccf63a4a0d6755a86feea2aa5a2efe9af44eb1eb0a578b21f593fe28fceace17b0a0badb52a66965c35bf456ea57dd3b905ebbe'