summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD41
-rw-r--r--falcon_ver.patch13
3 files changed, 48 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd2820ae152b..b70f9dc8aeb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = python-hug
- pkgdesc = Embrace the APIs of the future
- pkgver = 2.6.0
- pkgrel = 2
+ pkgdesc = A Python framework that makes developing APIs as simple as possible, but no simpler
+ pkgver = 2.6.1
+ pkgrel = 1
url = https://github.com/hugapi/hug
arch = any
license = MIT
- makedepends = python-setuptools
- depends = python
+ makedepends = python-pytest-runner
depends = python-falcon
- source = https://github.com/hugapi/hug/archive/2.6.0.tar.gz
- sha256sums = c54b04ed5ce0e436ddf9e8e00f838b4ed740a914cf3af9bef055e11375fc1ebe
+ depends = python-requests
+ depends = python-setuptools
+ source = https://files.pythonhosted.org/packages/source/h/hug/hug-2.6.1.tar.gz
+ source = falcon_ver.patch
+ sha256sums = b0edace2acb618873779c9ce6ecf9165db54fef95c22262f5700fcdd9febaec9
+ sha256sums = 9d059c9bafb31528d118ec78ff5c7e0028ecb98d417076f3e6d26ff117e1244d
pkgname = python-hug
- depends = python
- depends = python-falcon
-
diff --git a/PKGBUILD b/PKGBUILD
index 242acbb2c232..f3dc428276c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,32 @@
-_name="hug"
-pkgname=('python-hug')
-pkgver='2.6.0'
-pkgrel=2
-pkgdesc="Embrace the APIs of the future"
+# Maintainer: Filipe Nascimento <flipee at tuta dot io>
+
+pkgname=python-hug
+_module=${pkgname#python-}
+pkgver='2.6.1'
+pkgrel=1
+pkgdesc="A Python framework that makes developing APIs as simple as possible, but no simpler"
url="https://github.com/hugapi/hug"
-depends=('python' 'python-falcon')
-makedepends=('python-setuptools')
+depends=('python-falcon' 'python-requests' 'python-setuptools')
+makedepends=('python-pytest-runner')
license=('MIT')
arch=('any')
-source=("https://github.com/hugapi/hug/archive/${pkgver}.tar.gz")
-sha256sums=('c54b04ed5ce0e436ddf9e8e00f838b4ed740a914cf3af9bef055e11375fc1ebe')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/${_module}/${_module}-${pkgver}.tar.gz"
+ "falcon_ver.patch")
+sha256sums=('b0edace2acb618873779c9ce6ecf9165db54fef95c22262f5700fcdd9febaec9'
+ '9d059c9bafb31528d118ec78ff5c7e0028ecb98d417076f3e6d26ff117e1244d')
+
+prepare() {
+ cd ${_module}-${pkgver}
+ patch -p1 < ../falcon_ver.patch
+}
build() {
- cd "$srcdir/${_name}-${pkgver}"
- python setup.py build
- }
+ cd ${_module}-${pkgver}
+ python setup.py build
+}
package() {
- depends+=()
- cd "$srcdir/${_name}-${pkgver}"
- python setup.py install --root="$pkgdir" --optimize=1
- }
+ cd ${_module}-${pkgver}
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
diff --git a/falcon_ver.patch b/falcon_ver.patch
new file mode 100644
index 000000000000..677938d0ee4c
--- /dev/null
+++ b/falcon_ver.patch
@@ -0,0 +1,13 @@
+diff --git a/setup.py b/setup.py
+index 3d84b665..17e3da4e 100755
+--- a/setup.py
++++ b/setup.py
+@@ -96,7 +96,7 @@ setup(
+ entry_points={"console_scripts": ["hug = hug:development_runner.hug.interface.cli"]},
+ packages=["hug"],
+ requires=["falcon", "requests"],
+- install_requires=["falcon==2.0.0", "requests"],
++ install_requires=["falcon", "requests"],
+ setup_requires=["pytest-runner"],
+ tests_require=["pytest", "mock", "marshmallow"],
+ ext_modules=ext_modules,