summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..10948fb884e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-hypyutils
+ pkgdesc = HyDEV Utils for Python.
+ pkgver = 1.0.7+7f1eb2b4
+ pkgrel = 1
+ url = https://github.com/hykilpikonna/HyPyUtils
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = python-hypyutils::git+https://github.com/hykilpikonna/HyPyUtils.git#commit=7f1eb2b44310f3403cbb777e45941a8f891572dc
+ md5sums = SKIP
+
+pkgname = python-hypyutils
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..519dcbaf114f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Aleksana QWQ <me@aleksana.moe>
+
+pkgname=python-hypyutils
+pkgver=1.0.7+7f1eb2b4
+pkgrel=1
+pkgdesc="HyDEV Utils for Python."
+arch=('any')
+url='https://github.com/hykilpikonna/HyPyUtils'
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+
+_commit=7f1eb2b44310f3403cbb777e45941a8f891572dc
+
+source=("$pkgname::git+$url.git#commit=$_commit")
+md5sums=('SKIP')
+
+build() {
+ cd ${pkgname}
+ python setup.py build
+}
+
+package() {
+ cd ${pkgname}
+ python setup.py install --root="$pkgdir" --optimize=1
+}