summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..703b6f3d2a5b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat Apr 14 17:15:38 UTC 2018
+pkgbase = python-icecream-git
+ pkgdesc = Sweet and creamy print debugging.
+ pkgver = 1.3.71.cd0113a
+ pkgrel = 1
+ url = https://github.com/gruns/icecream
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = git+https://github.com/gruns/icecream.git
+ sha512sums = SKIP
+
+pkgname = python-icecream-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f528f06f948
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Lubosz Sarnecki <lubosz@gmail.com>
+
+pkgname=python-icecream-git
+pkgver=1.3.71.cd0113a
+pkgrel=1
+pkgdesc="Sweet and creamy print debugging."
+arch=("any")
+license=("MIT")
+url="https://github.com/gruns/icecream"
+depends=("python")
+makedepends=("python-setuptools")
+source=("git+https://github.com/gruns/icecream.git")
+sha512sums=("SKIP")
+
+pkgver() {
+ cd icecream
+ version=$(grep __version__ icecream/__init__.py | sed "s/__version__ = '//" | sed "s/'//")
+ hash=$(git log --pretty=format:'%h' -n 1)
+ revision=$(git rev-list --count HEAD)
+
+ echo $version.$revision.$hash
+}
+
+build() {
+ cd icecream
+ python setup.py build
+}
+
+package() {
+ cd icecream
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-icecream/LICENSE"
+}