summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD13
3 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ab2deac02ae..5d4c4d13f614 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = python-injector
pkgdesc = Python dependency injection framework, inspired by Guice.
- pkgver = 0.20.1
- pkgrel = 2
+ pkgver = 0.21.0
+ pkgrel = 1
url = http://github.com/alecthomas/injector
arch = any
license = BSD
makedepends = python-setuptools
depends = python
depends = python-typing_extensions
- source = https://files.pythonhosted.org/packages/source/i/injector/injector-0.20.1.tar.gz
- source = https://raw.githubusercontent.com/alecthomas/injector/0.20.0/COPYING
+ source = https://files.pythonhosted.org/packages/source/i/injector/injector-0.21.0.tar.gz
+ source = https://raw.githubusercontent.com/alecthomas/injector/0.21.0/COPYING
sha256sums = 8661b49a2f8309ce61e3a6a82b7acb5e225c4bde8e17d1610c893a670dff223a
sha256sums = 567278bc23fa55244f132af7164aa684940c75fa35b19c395899422cb92613ba
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c6e8daf6bfdd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 738de43beb32..6139dabda9cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,10 @@
-# Maintainer: Sophie Tauchert <sophie@999eagle.moe>
+# Maintainer: crimist <aur at crim dot ist>
+# Contributor: Sophie Tauchert <sophie@999eagle.moe>
_pkgname=injector
pkgname=python-${_pkgname}
-pkgver=0.20.1
-# temp fix while pypi version has no corresponding git tag
-_git_tag=0.20.0
-pkgrel=2
+pkgver=0.21.0
+pkgrel=1
pkgdesc="Python dependency injection framework, inspired by Guice."
arch=('any')
url="http://github.com/alecthomas/injector"
@@ -14,8 +13,8 @@ depends=('python' 'python-typing_extensions')
makedepends=('python-setuptools')
provides=()
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
- "https://raw.githubusercontent.com/alecthomas/injector/${_git_tag}/COPYING")
-sha256sums=('8661b49a2f8309ce61e3a6a82b7acb5e225c4bde8e17d1610c893a670dff223a'
+ "https://raw.githubusercontent.com/alecthomas/injector/${pkgver}/COPYING")
+sha256sums=('919eb6b9f96f40bf98fda34c79762b217bd1544d9adc35805ff2948e92356c9c'
'567278bc23fa55244f132af7164aa684940c75fa35b19c395899422cb92613ba')
build() {