summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD39
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab50c4f5de83
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-intellimouse-ctl-git
+ pkgdesc = A cross-platform command line tool and library for Microsoft's IntelliMouse devices.
+ pkgver = r24.b54424b
+ pkgrel = 1
+ url = https://github.com/madsl/Pro-IntelliMouse-Control-Panel
+ arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = git
+ depends = python
+ depends = python-hidapi
+ conflicts = python-intellimouse-ctl
+ source = python-intellimouse-ctl-git::git+https://github.com/madsl/Pro-IntelliMouse-Control-Panel.git
+ sha256sums = SKIP
+
+pkgname = python-intellimouse-ctl-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d4519017ec26
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Hannes Hegewald <mail at hns dot me>
+# Contributor: Andrej Radović <r.andrej@gmail.com>
+pkgname=python-intellimouse-ctl-git
+_name=${pkgname#python-}
+pkgver=r24.b54424b
+pkgrel=1
+pkgdesc="A cross-platform command line tool and library for Microsoft's IntelliMouse devices."
+url="https://github.com/madsl/Pro-IntelliMouse-Control-Panel"
+depends=(
+ 'python'
+ 'python-hidapi'
+)
+makedepends=(
+ 'python-build'
+ 'git'
+)
+license=('MIT')
+arch=('any')
+conflicts=("python-intellimouse-ctl")
+
+source=("${pkgname}::git+https://github.com/madsl/Pro-IntelliMouse-Control-Panel.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${pkgname}"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "${pkgname}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}