summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e13985fd2a14
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-intheam-git
+ pkgdesc = Python client module for the Inthe.AM REST API
+ pkgver = r3.ce25800
+ pkgrel = 1
+ url = https://github.com/aperezdc/intheam-python
+ arch = any
+ license = MIT
+ depends = python-click
+ source = python-intheam-git::git+https://github.com/aperezdc/intheam-python
+ sha512sums = SKIP
+
+pkgname = python-intheam-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4bec23631a6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
+pkgname='python-intheam-git'
+pkgdesc='Python client module for the Inthe.AM REST API'
+pkgver=r3.ce25800
+pkgrel=1
+arch=('any')
+license=('MIT')
+url='https://github.com/aperezdc/intheam-python'
+depends=('python-click')
+source=("${pkgname}::git+${url}")
+sha512sums=('SKIP')
+
+
+pkgver () {
+ cd "${pkgname}"
+ (
+ set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+
+package () {
+ cd "${pkgname}"
+ python3 setup.py install --root="${pkgdir}"
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}