summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df6a4655e13a..1423a477ee6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-jaxtyping
pkgdesc = Type annotations and runtime checking for shape and dtype of JAX arrays, and PyTrees.
- pkgver = 0.2.27
+ pkgver = 0.2.28
pkgrel = 1
url = https://github.com/google/jaxtyping
arch = any
@@ -14,7 +14,7 @@ pkgbase = python-jaxtyping
depends = python-typeguard
optdepends = python-jax: Original JAX type system support.
optdepends = python-pytest: Extension for pytest with jaxtyping plugin.
- source = python-jaxtyping-0.2.27.tar.gz::https://github.com/google/jaxtyping/archive/refs/tags/v0.2.27.tar.gz
- sha256sums = 2fd55da9f1ea906769046e237d3d4e5bc838d1cced48f6cee45fd1986dc9471b
+ source = python-jaxtyping-0.2.28.tar.gz::https://github.com/google/jaxtyping/archive/refs/tags/v0.2.28.tar.gz
+ sha256sums = 0d4ff620572f1355641990e193a1a694210d436e52d17cb68d10546c9c310b22
pkgname = python-jaxtyping
diff --git a/PKGBUILD b/PKGBUILD
index d2e2b628041f..dcf4b31c4841 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bershatsky <bepshatsky@yandex.ru>
pkgname=python-jaxtyping
_pkgname=${pkgname#python-}
-pkgver=0.2.27
+pkgver=0.2.28
pkgrel=1
pkgdesc='Type annotations and runtime checking for shape and dtype of JAX arrays, and PyTrees.'
arch=('any')
@@ -16,7 +16,7 @@ makedepends=('python-build' 'python-hatchling' 'python-installer' 'python-wheel'
optdepends=('python-jax: Original JAX type system support.'
'python-pytest: Extension for pytest with jaxtyping plugin.')
source=("$pkgname-$pkgver.tar.gz::https://github.com/google/$_pkgname/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('2fd55da9f1ea906769046e237d3d4e5bc838d1cced48f6cee45fd1986dc9471b')
+sha256sums=('0d4ff620572f1355641990e193a1a694210d436e52d17cb68d10546c9c310b22')
build() {
python -m build -nw $_pkgname-$pkgver