summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f7ec0ba39a6..74b1ee825e70 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-jsonargparse
pkgdesc = Parsing library for CLI options, configs, and environment variables
- pkgver = 4.27.7
+ pkgver = 4.28.0
pkgrel = 1
url = https://github.com/omni-us/jsonargparse
arch = any
@@ -18,7 +18,9 @@ pkgbase = python-jsonargparse
depends = python-requests
depends = python-responses
depends = python-ruyaml
- source = https://files.pythonhosted.org/packages/source/j/jsonargparse/jsonargparse-4.27.7.tar.gz
- sha256sums = 480fa4b2f4c75f267cbaa13fbf4dc86553f27252041d1d9066f2d0e25bf6389b
+ optdepends = python-omegaconf
+ optdepends = python-jsonnet
+ source = https://files.pythonhosted.org/packages/source/j/jsonargparse/jsonargparse-4.28.0.tar.gz
+ sha256sums = ac835a290ef18cc2a5309e6bfa8ada9c5d63f46ff18701583fc8f3e95314679c
pkgname = python-jsonargparse
diff --git a/PKGBUILD b/PKGBUILD
index 3ed39a3b172d..83f6c1188ccc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=python-jsonargparse
_name=${pkgname#python-}
-pkgver=4.27.7
+pkgver=4.28.0
pkgrel=1
pkgdesc='Parsing library for CLI options, configs, and environment variables'
arch=('any')
@@ -24,11 +24,15 @@ depends=(
'python-responses'
'python-ruyaml'
)
+optdepends=(
+ 'python-omegaconf'
+ 'python-jsonnet'
+)
checkdepends=(
'python-coverage'
)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('480fa4b2f4c75f267cbaa13fbf4dc86553f27252041d1d9066f2d0e25bf6389b')
+sha256sums=('ac835a290ef18cc2a5309e6bfa8ada9c5d63f46ff18701583fc8f3e95314679c')
build() {
cd "${srcdir}/${_name}-${pkgver}"