summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81a24fd44854
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-kiwi-gtk
+ pkgdesc = A framework and a set of enhanced widgets based on PyGTK
+ pkgver = 3.0.3
+ pkgrel = 1
+ url = https://www.stoq.com.br
+ arch = any
+ license = LGPL
+ depends = python
+ depends = python-setuptools
+ optdepends =
+ conflicts = python-stoq-kiwi
+ source = https://pypi.python.org/packages/source/k/kiwi-gtk/kiwi-gtk-3.0.3.tar.gz
+ md5sums = cd129fd212e803944dec40024f56d696
+
+pkgname = python-kiwi-gtk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c8cbf2a524a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Vinicius Correa <vinicius.correa at zoho dot com>
+_pkgname=kiwi-gtk
+pkgname=python-kiwi-gtk
+pkgver=3.0.3
+pkgrel=1
+pkgdesc="A framework and a set of enhanced widgets based on PyGTK"
+arch=('any')
+url="https://www.stoq.com.br"
+license=('LGPL')
+depends=('python' 'python-setuptools')
+optdepends=('')
+conflicts=('python-stoq-kiwi')
+source=("https://pypi.python.org/packages/source/k/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('cd129fd212e803944dec40024f56d696')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}