summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b5889bdadca..b5d16a4a55f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python2-kwant
pkgdesc = Python package for numerical calculations on tight-binding models with a strong focus on quantum transport
- pkgver = 1.0.4
+ pkgver = 1.1.0
pkgrel = 1
url = http://kwant-project.org/
arch = any
@@ -13,10 +13,10 @@ pkgbase = python2-kwant
depends = python2-tinyarray
optdepends = python2-matplotlib: needed for plotting support and the tutorial
optdepends = mumps: a sparse linear algebra library for speed up and memory usage reduction
- source = http://downloads.kwant-project.org/kwant/kwant-1.0.4.tar.gz
- source = http://downloads.kwant-project.org/kwant/kwant-1.0.4.tar.gz.asc
- md5sums = 78c7c84c2d5fde2f8f24212b00447b78
- md5sums = SKIP
+ source = http://downloads.kwant-project.org/kwant/kwant-1.1.0.tar.gz
+ source = http://downloads.kwant-project.org/kwant/kwant-1.1.0.tar.gz.asc
+ sha1sums = a18131c57ebeb2b0052ddba6ffcd72f65913a1bf
+ sha1sums = SKIP
pkgname = python2-kwant
diff --git a/PKGBUILD b/PKGBUILD
index be46d76b204f..26eb01fac961 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jörg Behrmann <behrmann@physik.fu-berlin.de>
# Contributor: Max Schlemmer <max.schlemmer@gmail.com>
pkgname=python2-kwant
-pkgver=1.0.4
+pkgver=1.1.0
pkgrel=1
pkgdesc="Python package for numerical calculations on tight-binding models with a strong focus on quantum transport"
arch=('any')
@@ -17,8 +17,8 @@ source=(
http://downloads.kwant-project.org/kwant/kwant-$pkgver.tar.gz
http://downloads.kwant-project.org/kwant/kwant-$pkgver.tar.gz.asc
)
-md5sums=('78c7c84c2d5fde2f8f24212b00447b78'
- 'SKIP')
+sha1sums=('a18131c57ebeb2b0052ddba6ffcd72f65913a1bf'
+ 'SKIP')
validpgpkeys=('52299057FAD799653C4F088AC3F147F5980F3535')
build() {
@@ -35,6 +35,6 @@ package() {
}
check() {
- cd "$srcdir/kwant-$pkgver/kwant"
- python2 -c 'import kwant; kwant.test()'
+ cd "$srcdir/kwant-$pkgver"
+ python2 setup.py test
}