summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b168c0888ae..61c16d94e8ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-leapmotion
pkgdesc = The Leapmotion python interface, compiled for python 3
pkgver = 2.3.1
- pkgrel = 2
+ pkgrel = 3
url = https://developer.leapmotion.com/downloads
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 7f3cf95b847d..d1f511593afb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-leapmotion
pkgver=2.3.1
-pkgrel=2
+pkgrel=3
pkgdesc="The Leapmotion python interface, compiled for python 3"
arch=('i686' 'x86_64')
makedepends=('swig3' 'leap-motion-sdk' 'python-setuptools')
@@ -16,7 +16,7 @@ md5sums=('ef0b9321730ef63d62363281b05f453f'
build() {
cp /usr/include/Leap{.h,Math.h} .
patch -i fix-interface.patch /usr/include/Leap.i -o Leap.i
- swig -c++ -python -o LeapPython.cpp -interface LeapPython Leap.i
+ swig-3 -c++ -python -o LeapPython.cpp -interface LeapPython Leap.i
LEAP_VERSION="$pkgver" python setup.py build
}