summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cfe0d02de922
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-markdown-figures-git
+ pkgdesc = Extension for Python-Markdown to parse figure elements, optionally with a caption.
+ pkgver = 2.59e8be5
+ pkgrel = 1
+ url = http://github.com/helderco/markdown-figures
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = python-markdown
+ conflicts = python-markdown-figures
+ source = python-markdown-figures-git::git://github.com/helderco/markdown-figures
+ md5sums = SKIP
+
+pkgname = python-markdown-figures-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d5a97f3ee13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Can Altıparmak (gulaghad) <can6dev <AT> gmail <DOT> com>
+
+pkgname=python-markdown-figures-git
+pkgver=2.59e8be5
+pkgrel=1
+pkgdesc="Extension for Python-Markdown to parse figure elements, optionally with a caption."
+arch=('any')
+url="http://github.com/helderco/markdown-figures"
+license=('GPL2')
+depends=('python-markdown')
+makedepends=('git')
+conflicts=('python-markdown-figures')
+source=("$pkgname"::'git://github.com/helderco/markdown-figures')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ site=$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")
+ install -D "$srcdir/$pkgname/captions.py" "$pkgdir$site/markdown/extensions/captions.py"
+}