summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD26
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e7b197bb66a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-meld3
+ pkgdesc = An HTML/XML templating engine
+ pkgver = 1.0.2
+ pkgrel = 2
+ url = https://github.com/supervisor/meld3
+ arch = any
+ license = Repoze
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/m/meld3/meld3-1.0.2.tar.gz
+ sha256sums = f7b754a0fde7a4429b2ebe49409db240b5699385a572501bb0d5627d299f9558
+
+pkgname = python-meld3
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9b97681014e9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+*.zip
+*.jar
+*.tar
+*.tgz
+*.tbz2
+*.gz
+*.bz2
+*.xz
+*.gem
+*.run
+*.deb
+*.rpm
+*.sig
+*.log
+/src
+/pkg
+*.kate-swp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b97c7100eb2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+# Contributor: Daniele Paolella <dp@mcrservice.it>
+
+pkgname=python-meld3
+_libname=meld3
+pkgver=1.0.2
+pkgrel=2
+pkgdesc="An HTML/XML templating engine"
+arch=('any')
+url="https://github.com/supervisor/meld3"
+license=('Repoze')
+depends=('python')
+makedepends=('python-setuptools')
+source=(https://files.pythonhosted.org/packages/source/${_libname:0:1}/$_libname/$_libname-$pkgver.tar.gz)
+sha256sums=('f7b754a0fde7a4429b2ebe49409db240b5699385a572501bb0d5627d299f9558')
+
+build() {
+ cd "$srcdir"/meld3-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir"/meld3-$pkgver
+ python setup.py install -O1 --skip-build --prefix=/usr --root="$pkgdir"
+ install -m0644 -D LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}