summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 15 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 401ce8051a6e..902fc6706741 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,20 @@
pkgbase = python-mmclassification-git
pkgdesc = OpenMMLab Image Classification Toolbox and Benchmark
- pkgver = 0.1.0.r458.894a82ea
+ pkgver = 0.22.0.r2.5a67bc8a
pkgrel = 1
url = https://github.com/open-mmlab/mmclassification
arch = any
license = Apache
makedepends = git
makedepends = python-setuptools
+ depends = python-matplotlib
depends = python-mmcv
depends = python-numpy
depends = python-pytorch
+ optdepends = python-albumentations
+ optdepends = python-colorama
+ optdepends = python-requests
+ optdepends = python-rich
provides = python-mmclassification
conflicts = python-mmclassification
source = mmclassification::git+https://github.com/open-mmlab/mmclassification.git
diff --git a/PKGBUILD b/PKGBUILD
index 9bbb74a48a7f..4428b58a11e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
_pkgname=mmclassification
pkgname=python-mmclassification-git
-_pkgver=0.1.0
-pkgver=0.1.0.r458.894a82ea
+pkgver=0.22.0.r2.5a67bc8a
pkgrel=1
pkgdesc='OpenMMLab Image Classification Toolbox and Benchmark'
arch=('any')
url='https://github.com/open-mmlab/mmclassification'
license=('Apache')
depends=(
+ python-matplotlib
python-mmcv
python-numpy
python-pytorch
@@ -18,6 +18,12 @@ makedepends=(
git
python-setuptools
)
+optdepends=(
+ python-albumentations
+ python-colorama
+ python-requests
+ python-rich
+)
provides=(python-mmclassification)
conflicts=(python-mmclassification)
source=("${_pkgname}::git+https://github.com/open-mmlab/mmclassification.git")
@@ -25,7 +31,7 @@ sha512sums=('SKIP')
pkgver() {
cd "${_pkgname}"
- printf "%s.r%s.%s" "${_pkgver}" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')" | sed "s/^v//"
}
build() {