summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
-rw-r--r--patch.i0.c12
3 files changed, 8 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79fdce40fcc4..d9dfd22af8d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-msmbuilder
pkgdesc = A python package which implements a series of statistical models for high-dimensional time-series
- pkgver = 3.3.1
- pkgrel = 5
+ pkgver = 3.8.0
+ pkgrel = 1
url = http://msmbuilder.org/
arch = i686
arch = x86_64
@@ -13,10 +13,8 @@ pkgbase = python-msmbuilder
depends = python-pytables
depends = python-numpydoc
options = !libtool
- source = https://github.com/msmbuilder/msmbuilder/archive/3.3.1.tar.gz
- source = patch.i0.c
- sha1sums = fcb5ad6fabb5aead4c78d3fed782665d090c0caa
- sha1sums = f0129777e7f9fb28074b86d47d6bb8b94f763063
+ source = https://github.com/msmbuilder/msmbuilder/archive/3.8.0.tar.gz
+ sha1sums = dce2a640ecd277554b9a425d094737cd136f509d
pkgname = python-msmbuilder
diff --git a/PKGBUILD b/PKGBUILD
index d94b8bd81774..e152641fc8a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=('python-msmbuilder')
-pkgver=3.3.1
-pkgrel=5
+pkgver=3.8.0
+pkgrel=1
pkgdesc='A python package which implements a series of statistical models for high-dimensional time-series'
url='http://msmbuilder.org/'
license=("LGPL")
@@ -12,17 +12,8 @@ depends=('python-mdtraj' 'python-cvxopt' 'python-scikit-learn' 'python-pytables'
optdepends=()
makedepends=('python-setuptools')
options=('!libtool')
-source=("https://github.com/msmbuilder/msmbuilder/archive/${pkgver}.tar.gz"
- "patch.i0.c")
-sha1sums=('fcb5ad6fabb5aead4c78d3fed782665d090c0caa'
- 'f0129777e7f9fb28074b86d47d6bb8b94f763063')
-
-prepare() {
- cd "$srcdir"
- cp patch.i0.c msmbuilder-3.3.1/msmbuilder/hmm/cephes/
- cd msmbuilder-3.3.1/msmbuilder/hmm/cephes/
- patch i0.c < patch.i0.c
-}
+source=("https://github.com/msmbuilder/msmbuilder/archive/${pkgver}.tar.gz")
+sha1sums=('dce2a640ecd277554b9a425d094737cd136f509d')
build() {
msg2 "Building msmbuilder - Python 3"
diff --git a/patch.i0.c b/patch.i0.c
deleted file mode 100644
index b4f526012da9..000000000000
--- a/patch.i0.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- i0.c_old 2015-11-19 23:33:45.000000000 +0100
-+++ i0.c 2016-03-09 14:17:04.214784592 +0100
-@@ -75,8 +75,8 @@
- */
-
- #include "cephes.h"
--#include "mconf.h"
- #include "math.h"
-+#include "mconf.h"
-
- /* Chebyshev coefficients for exp(-x) I0(x)
- * in the interval [0,8].