summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4e0cb0347a3..c7db330a3b70 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-mwoauth
pkgdesc = Generic MediaWiki OAuth handshake helper for Python
- pkgver = 0.3.7
- pkgrel = 2
+ pkgver = 0.3.8
+ pkgrel = 1
url = https://github.com/mediawiki-utilities/python-mwoauth
arch = any
license = MIT
makedepends = python-setuptools
depends = python-pyjwt
depends = python-requests-oauthlib
- source = https://pypi.org/packages/source/m/mwoauth/mwoauth-0.3.7.tar.gz
- sha512sums = e16db48633d4f476b4f46e22dce06ae355e2ff07926ea7c2ccad56a3548d471711556f87bc8abcae454b61943c1f8c1b24b42fec1a28906f0d4196c045bf339a
+ source = https://pypi.org/packages/source/m/mwoauth/mwoauth-0.3.8.tar.gz
+ sha512sums = 29e70f7e40e4a7625c50ba3b619124c33af2cb82139895eaa834e161e4650a6b08e987f04b2a2b09395f625b146c052bb04a512b1939a8b931947b20dee1f6df
pkgname = python-mwoauth
diff --git a/PKGBUILD b/PKGBUILD
index a0386391d3ae..ff77b9afabb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,24 @@
# Contributor: Simon Legner <Simon.Legner@gmail.com>
_base=mwoauth
pkgname=python-${_base}
-pkgver=0.3.7
-pkgrel=2
+pkgver=0.3.8
+pkgrel=1
pkgdesc="Generic MediaWiki OAuth handshake helper for Python"
license=(MIT)
-arch=('any')
+arch=(any)
url="https://github.com/mediawiki-utilities/${pkgname}"
depends=(python-pyjwt python-requests-oauthlib)
makedepends=(python-setuptools)
source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
-sha512sums=('e16db48633d4f476b4f46e22dce06ae355e2ff07926ea7c2ccad56a3548d471711556f87bc8abcae454b61943c1f8c1b24b42fec1a28906f0d4196c045bf339a')
+sha512sums=('29e70f7e40e4a7625c50ba3b619124c33af2cb82139895eaa834e161e4650a6b08e987f04b2a2b09395f625b146c052bb04a512b1939a8b931947b20dee1f6df')
build() {
- cd "${_base}-${pkgver}"
+ cd ${_base}-${pkgver}
python setup.py build
}
package() {
- cd "${_base}-${pkgver}"
- export PYTHONHASHSEED=0
+ cd ${_base}-${pkgver}
PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}