summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f50219b5eb32
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-nvidia-ml-py3-git
+ pkgdesc = Python 3 Bindings for the NVIDIA Management Library
+ pkgver = r5.2b04f5d
+ pkgrel = 1
+ url = https://github.com/nicolargo/nvidia-ml-py3
+ arch = any
+ license = custom
+ makedepends = python-setuptools
+ depends = python
+ source = git://github.com/nicolargo/nvidia-ml-py3.git
+ md5sums = SKIP
+
+pkgname = python-nvidia-ml-py3-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7543fda99b75
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+nvidia-ml-py3/
+*.tar*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73835ae95ac3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=python-nvidia-ml-py3-git
+_module='nvidia-ml-py3'
+pkgver=r5.2b04f5d
+pkgrel=1
+pkgdesc="Python 3 Bindings for the NVIDIA Management Library"
+url="https://github.com/nicolargo/nvidia-ml-py3"
+depends=(python)
+makedepends=(python-setuptools)
+license=('custom')
+arch=('any')
+source=("git://github.com/nicolargo/nvidia-ml-py3.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_module"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_module}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
+