summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD36
-rwxr-xr-xocp-vscode5
4 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1b091f07938
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = python-ocp-vscode
+ pkgdesc = OCP CAD Viewer for VSCode (also for Jupyter and standalone)
+ pkgver = 2.6.1
+ pkgrel = 1
+ url = https://github.com/bernhard-42/vscode-ocp-cad-viewer
+ arch = any
+ license = Apache-2.0
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python-ocp-tessellate
+ depends = python-requests
+ depends = python-ipykernel
+ depends = python-orjson
+ depends = python-websockets
+ depends = python-pyaml
+ depends = python-flask
+ depends = python-flask-sock
+ depends = python-click
+ source = https://files.pythonhosted.org/packages/source/o/ocp_vscode/ocp_vscode-2.6.1.tar.gz
+ source = ocp-vscode
+ sha256sums = 9e11aa89f6e60733846e553df4e347c19b82c8ca84912c43ce844af426daae7e
+ sha256sums = 4fd564ab59d38072be61cfa5159a297e7222879265ffea94684296bfe550aa26
+
+pkgname = python-ocp-vscode
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d6d6cb985138
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+*.tar.xz
+*.tar.zst
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00b96dfc4253
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+pkgname=python-ocp-vscode
+_name=ocp_vscode
+pkgdesc="OCP CAD Viewer for VSCode (also for Jupyter and standalone)"
+pkgver=2.6.1
+pkgrel=1
+arch=('any')
+url="https://github.com/bernhard-42/vscode-ocp-cad-viewer"
+license=('Apache-2.0')
+depends=('python-ocp-tessellate' 'python-requests' 'python-ipykernel' 'python-orjson'
+ 'python-websockets' 'python-pyaml' 'python-flask' 'python-flask-sock' 'python-click')
+makedepends=('python-build' 'python-installer' 'python-wheel')
+#checkdepends=('python-pytest')
+source=("https://files.pythonhosted.org/packages/source/o/$_name/$_name-$pkgver.tar.gz"
+ "ocp-vscode")
+sha256sums=('9e11aa89f6e60733846e553df4e347c19b82c8ca84912c43ce844af426daae7e'
+ '4fd564ab59d38072be61cfa5159a297e7222879265ffea94684296bfe550aa26')
+
+build() {
+ cd $_name-$pkgver
+ python -m build --wheel --no-isolation
+
+}
+
+package() {
+ cd $_name-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
+
+ # install python executable to simplify running as standalone
+ install -Dm755 -t "$pkgdir/usr/bin" "../ocp-vscode"
+}
+
+# The test files aren't actually using pytest, and fail to load
+#check() {
+# cd $_name-$pkgver
+# pytest
+#}
diff --git a/ocp-vscode b/ocp-vscode
new file mode 100755
index 000000000000..42025451810d
--- /dev/null
+++ b/ocp-vscode
@@ -0,0 +1,5 @@
+#!/usr/bin/python
+from ocp_vscode import __main__
+
+if __name__ == "__main__":
+ __main__.main()