summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 3 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad48b009d3e0..24368aa8fd9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-onnx
pkgdesc = Open Neural Network Exchange
pkgver = 1.15.0
- pkgrel = 2
+ pkgrel = 3
epoch = 1
url = https://onnx.ai
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 482217e8d405..2b22db6bf65a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-onnx
pkgver=1.15.0
-pkgrel=2
+pkgrel=3
epoch=1
pkgdesc='Open Neural Network Exchange'
arch=('x86_64')
@@ -30,12 +30,11 @@ sha512sums=('SKIP')
prepare() {
cd "${pkgname}"
git submodule update --init --recursive
- # bump CMAKE_CXX_STANDARD to 17, see also https://github.com/onnx/onnx/pull/5119
- sed -i 's#CMAKE_CXX_STANDARD 14#CMAKE_CXX_STANDARD 17#' CMakeLists.txt
}
build() {
cd "${pkgname}"
+ CMAKE_ARGS="-DCMAKE_CXX_STANDARD=17" \
python -m build --wheel --no-isolation
}