summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
-rw-r--r--nlohmann-json.diff11
3 files changed, 26 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c051c34c41a8..b2a31eb92257 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-onnxruntime
pkgdesc = Cross-platform, high performance scoring engine for ML models
- pkgver = 1.0.0
- pkgrel = 5
+ pkgver = 1.1.0
+ pkgrel = 2
url = https://github.com/microsoft/onnxruntime
arch = x86_64
license = MIT
@@ -14,16 +14,18 @@ pkgbase = python-onnxruntime
makedepends = pybind11
makedepends = python-setuptools
makedepends = cub
+ makedepends = nlohmann-json
depends = protobuf
depends = re2
depends = python-numpy
- source = git+https://github.com/microsoft/onnxruntime#tag=v1.0.0
+ source = git+https://github.com/microsoft/onnxruntime#tag=v1.1.0
source = git+https://github.com/HowardHinnant/date.git
source = eigen::git+https://github.com/eigenteam/eigen-git-mirror.git
source = git+https://github.com/google/gemmlowp.git
source = git+https://github.com/google/nsync.git
source = git+https://github.com/onnx/onnx.git
source = build-fixes.patch
+ source = nlohmann-json.diff
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
@@ -31,6 +33,7 @@ pkgbase = python-onnxruntime
sha512sums = SKIP
sha512sums = SKIP
sha512sums = da8e27ff0011fb207ee8a6f8675160eb85cb8711f01050fa7454234242af141951cb5bba52fa50b98cf8567b8faa973565dfef37f4daa2219a42cf26e03c86b5
+ sha512sums = 1c70cf6ae50e1aba97e4eec3da40b076c4cf1e6a48a92d189045fe700d71bfbcbef937183f917e6c37f4271ce39fef68d9d01e9630f3f928a0bb35df248f63a4
pkgname = python-onnxruntime
@@ -40,6 +43,6 @@ pkgname = python-onnxruntime-cuda
depends = python-numpy
depends = cuda
depends = cudnn
- provides = python-onnxruntime=1.0.0
+ provides = python-onnxruntime=1.1.0
conflicts = python-onnxruntime
diff --git a/PKGBUILD b/PKGBUILD
index 02e1176631b5..f8fa64337754 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgbase=python-onnxruntime
pkgname=(python-onnxruntime python-onnxruntime-cuda)
-pkgver=1.0.0
+pkgver=1.1.0
pkgdesc='Cross-platform, high performance scoring engine for ML models'
-pkgrel=5
+pkgrel=2
arch=(x86_64)
url='https://github.com/microsoft/onnxruntime'
license=(MIT)
depends=(protobuf re2 python-numpy)
-makedepends=(git cmake cuda cudnn gtest gmock pybind11 python-setuptools cub)
+makedepends=(git cmake cuda cudnn gtest gmock pybind11 python-setuptools cub nlohmann-json)
# not de-vendored libraries
# eigen: API changes a lot since extra/eigen 3.3.7 to the commit onnxruntime uses
# onnx: onnxruntime requires headers, which are not installed in python-onnx
@@ -19,14 +19,16 @@ source=("git+https://github.com/microsoft/onnxruntime#tag=v$pkgver"
"git+https://github.com/google/gemmlowp.git"
"git+https://github.com/google/nsync.git"
"git+https://github.com/onnx/onnx.git"
- build-fixes.patch)
+ build-fixes.patch
+ nlohmann-json.diff)
sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'da8e27ff0011fb207ee8a6f8675160eb85cb8711f01050fa7454234242af141951cb5bba52fa50b98cf8567b8faa973565dfef37f4daa2219a42cf26e03c86b5')
+ 'da8e27ff0011fb207ee8a6f8675160eb85cb8711f01050fa7454234242af141951cb5bba52fa50b98cf8567b8faa973565dfef37f4daa2219a42cf26e03c86b5'
+ '1c70cf6ae50e1aba97e4eec3da40b076c4cf1e6a48a92d189045fe700d71bfbcbef937183f917e6c37f4271ce39fef68d9d01e9630f3f928a0bb35df248f63a4')
prepare() {
cd onnxruntime
@@ -35,6 +37,7 @@ prepare() {
rm -v onnxruntime/core/util/protobuf_parsing_utils.{h,cc}
echo "#include <google/protobuf/io/zero_copy_stream_impl.h>" >> onnxruntime/core/util/protobuf_parsing_utils.h
patch -Np1 -i ../build-fixes.patch
+ patch -Np1 -i ../nlohmann-json.diff
git submodule init
for mod in date eigen gemmlowp nsync onnx ; do
diff --git a/nlohmann-json.diff b/nlohmann-json.diff
new file mode 100644
index 000000000000..fdab11dd0318
--- /dev/null
+++ b/nlohmann-json.diff
@@ -0,0 +1,11 @@
+--- a/onnxruntime/core/session/inference_session_utils.h 2019-12-20 15:13:30.265861841 +0800
++++ b/onnxruntime/core/session/inference_session_utils.h 2019-12-20 15:13:22.132528563 +0800
+@@ -6,7 +6,7 @@
+ #include "core/session/inference_session.h"
+ #include "core/framework/session_options.h"
+ #include "core/common/common.h"
+-#include "single_include/nlohmann/json.hpp"
++#include <nlohmann/json.hpp>
+
+ using json = nlohmann::json;
+