summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8bafa0f7146f..329efab82a69 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-onnxruntime
pkgdesc = Cross-platform, high performance scoring engine for ML models
pkgver = 0.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/microsoft/onnxruntime
arch = x86_64
license = MIT
@@ -13,7 +13,8 @@ pkgbase = python-onnxruntime
makedepends = gmock
makedepends = pybind11
makedepends = python-setuptools
- depends = protobuf>=3.7.1
+ makedepends = protobuf>=3.7.1
+ depends = protobuf
depends = re2
depends = python-numpy
source = git+https://github.com/microsoft/onnxruntime#tag=v0.4.0
@@ -36,7 +37,7 @@ pkgbase = python-onnxruntime
pkgname = python-onnxruntime
pkgname = python-onnxruntime-cuda
- depends = protobuf>=3.7.1
+ depends = protobuf
depends = re2
depends = python-numpy
depends = cuda
diff --git a/PKGBUILD b/PKGBUILD
index bb16dcb77369..a235cd51fe0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@ pkgbase=python-onnxruntime
pkgname=(python-onnxruntime python-onnxruntime-cuda)
pkgver=0.4.0
pkgdesc='Cross-platform, high performance scoring engine for ML models'
-pkgrel=1
+pkgrel=2
arch=(x86_64)
url='https://github.com/microsoft/onnxruntime'
license=(MIT)
+depends=(protobuf re2 python-numpy)
# protobuf 3.7.0 has an issue, which breaks building of onnxruntime
# https://github.com/protocolbuffers/protobuf/issues/5869
-depends=('protobuf>=3.7.1' re2 python-numpy)
-makedepends=(git cmake cuda cudnn gtest gmock pybind11 python-setuptools)
+makedepends=(git cmake cuda cudnn gtest gmock pybind11 python-setuptools 'protobuf>=3.7.1' )
# not de-vendored libraries
# eigen: API changes a lot since extra/eigen 3.3.7 to the commit onnxruntime uses
# onnx: onnxruntime requires headers, which are not installed in python-onnx