summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD9
3 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02b3e32aed42..37ea5e5dffe6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = python-orderedattrdict
pkgdesc = An ordered Python dictionary with attribute-style access
- pkgver = 1.5.1
- pkgrel = 2
+ pkgver = 1.6.0
+ pkgrel = 1
url = https://github.com/sanand0/orderedattrdict
arch = any
license = MIT
checkdepends = python-yaml
makedepends = python-setuptools
depends = python
- source = https://github.com/sanand0/orderedattrdict/archive/v1.5.1.tar.gz
- sha256sums = d09b2963361b6e13fb067db257559616699c137cab0cc284579d58c044d13106
+ optdepends = python-yaml: for working with YAML files
+ source = orderedattrdict-1.6.0.tar.gz::https://github.com/sanand0/orderedattrdict/archive/v1.6.0.tar.gz
+ sha256sums = 6aa52111168b3cd5884d2118e911741aff1eb6240fcca6308a89c7d378bc7413
pkgname = python-orderedattrdict
diff --git a/.gitignore b/.gitignore
index bcb56b4bd3e8..ce0c44eaf5c1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,6 @@
src
pkg
*.pkg.tar.xz
+*.pkg.tar.zst
*.tar.gz
*.log
diff --git a/PKGBUILD b/PKGBUILD
index b47ed23ff48b..e30291c85544 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: Blair Bonnett <blair dot bonnett at gmail dot com>
pkgname=python-orderedattrdict
-pkgver=1.5.1
-pkgrel=2
+pkgver=1.6.0
+pkgrel=1
pkgdesc="An ordered Python dictionary with attribute-style access"
url="https://github.com/sanand0/orderedattrdict"
arch=('any')
depends=('python')
+optdepends=('python-yaml: for working with YAML files')
makedepends=('python-setuptools')
checkdepends=('python-yaml')
license=('MIT')
source=(
- "https://github.com/sanand0/orderedattrdict/archive/v$pkgver.tar.gz"
+ "orderedattrdict-$pkgver.tar.gz::https://github.com/sanand0/orderedattrdict/archive/v$pkgver.tar.gz"
)
sha256sums=(
- 'd09b2963361b6e13fb067db257559616699c137cab0cc284579d58c044d13106'
+ '6aa52111168b3cd5884d2118e911741aff1eb6240fcca6308a89c7d378bc7413'
)
build() {