summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD23
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31b1a87fde27
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = python-pandas-ta
+ pkgdesc = Pandas TA - A Technical Analysis Library in Python 3
+ pkgver = 0.3.14
+ pkgrel = 1
+ url = https://github.com/twopirllc/pandas-ta
+ arch = x86_64
+ license = MIT
+ source = https://github.com/twopirllc/pandas-ta/archive/refs/tags/0.3.14.zip
+ sha256sums = ae3fea05a3c6afee9e02eb417037a6c7990acc2b5ee7815a5697f7696a9b6b26
+
+pkgname = python-pandas-ta
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28c2f3651822
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jose Carlos Temprado <thempra@overxet.com>
+
+pkgname=python-pandas-ta
+pkgver=0.3.14
+pkgrel=1
+pkgdesc='Pandas TA - A Technical Analysis Library in Python 3'
+arch=('x86_64')
+url="https://github.com/twopirllc/pandas-ta"
+license=('MIT')
+source=("https://github.com/twopirllc/pandas-ta/archive/refs/tags/$pkgver.zip")
+sha256sums=('ae3fea05a3c6afee9e02eb417037a6c7990acc2b5ee7815a5697f7696a9b6b26')
+
+build() {
+ cd pandas-ta-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd pandas-ta-${pkgver}
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ rm -rf "$pkgdir"/usr/lib/python*/site-packages/tests
+
+}