summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 25 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bdd4a6b24d55..4b4c9f041364 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-photutils
pkgdesc = Astropy Affiliated package for image photometry utilities
- pkgver = 1.11.0
+ pkgver = 1.12.0
pkgrel = 1
url = http://photutils.readthedocs.io
arch = i686
@@ -17,7 +17,7 @@ pkgbase = python-photutils
makedepends = python-wheel
makedepends = python-build
makedepends = python-installer
- makedepends = python-extension-helpers
+ makedepends = python-extension-helpers>=1
makedepends = python-numpy
makedepends = python-sphinx-astropy
makedepends = python-astropy
@@ -26,16 +26,16 @@ pkgbase = python-photutils
makedepends = python-scikit-image
makedepends = python-shapely
makedepends = graphviz
- source = https://files.pythonhosted.org/packages/source/p/photutils/photutils-1.11.0.tar.gz
- md5sums = ccd7139782232feee673264e9f9b3554
+ source = https://files.pythonhosted.org/packages/source/p/photutils/photutils-1.12.tar.gz
+ md5sums = ca4a1f47f68c320217328b5c63df0eca
pkgname = python-photutils
- depends = python>=3.9
- depends = python-numpy>=1.22
+ depends = python>=3.10
+ depends = python-numpy>=1.23
depends = python-astropy>=5.1
- optdepends = python-scipy>=1.7.2: To power a variety of features in several modules (strongly recommended)
- optdepends = python-scikit-image>=0.19: Used in deblend_sources for deblending segmented sources
- optdepends = python-scikit-learn>=1.0: Used in DBSCANGroup to create star groups
+ optdepends = python-scipy>=1.8: To power a variety of features in several modules (strongly recommended)
+ optdepends = python-scikit-image>=0.20: Used in deblend_sources for deblending segmented sources
+ optdepends = python-scikit-learn>=1.1: Used in DBSCANGroup to create star groups
optdepends = python-matplotlib>=3.5: To power a variety of plotting features (e.g. plotting apertures
optdepends = python-gwcs>=0.18: Used in make_gwcs to create a simple celestial gwcs object
optdepends = python-bottleneck: Improves the performance of sigma clipping and other functionality that may require computing statistics on arrays with NaN values
diff --git a/PKGBUILD b/PKGBUILD
index a41188821a2d..b5569353e7c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
pkgbase=python-photutils
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=1.11.0
+pkgver=1.12.0
+_pkgver=${pkgver/.0}
pkgrel=1
pkgdesc="Astropy Affiliated package for image photometry utilities"
arch=('i686' 'x86_64')
@@ -13,7 +14,7 @@ makedepends=('cython>=3.0.0'
'python-wheel'
'python-build'
'python-installer'
- 'python-extension-helpers'
+ 'python-extension-helpers>=1'
'python-numpy'
'python-sphinx-astropy'
'python-astropy'
@@ -28,7 +29,8 @@ checkdepends=('python-pytest-astropy-header'
'python-matplotlib'
'python-scikit-learn'
'python-gwcs') # scipy scikit-image shapely rasterio already in makedepends
-source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+#source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${_pkgver}.tar.gz")
# "https://github.com/astropy/photutils-datasets/raw/main/data/M6707HH.fits"
# "https://github.com/astropy/photutils-datasets/raw/main/data/SA112-SF1-001R1.fit.gz"
# "https://github.com/astropy/photutils-datasets/raw/main/data/SA112-SF1-ra-dec-list.txt"
@@ -40,14 +42,14 @@ source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname
# "https://github.com/astropy/photutils-datasets/raw/main/data/spitzer_example_catalog.xml"
# "https://github.com/astropy/photutils-datasets/raw/main/data/spitzer_example_image.fits"
# 'datasets-use-local.patch')
-md5sums=('ccd7139782232feee673264e9f9b3554')
+md5sums=('ca4a1f47f68c320217328b5c63df0eca')
get_pyver() {
python -c "import sys; print('$1'.join(map(str, sys.version_info[:2])))"
}
#prepare() {
-# cd ${srcdir}/${_pyname}-${pkgver}
+# cd ${srcdir}/${_pyname}-${_pkgver}
#
# sed -e "/bool8/a \ ignore:jsonschema.exceptions.RefResolutionError is deprecated:DeprecationWarning" \
# -i setup.cfg
@@ -56,24 +58,24 @@ get_pyver() {
#}
build() {
- cd ${srcdir}/${_pyname}-${pkgver}
- python -m build --wheel --no-isolation
+ cd ${srcdir}/${_pyname}-${_pkgver}
+ python -m build --wheel --no-isolation --skip-dependency-check
msg "Building Docs"
PYTHONPATH="../build/lib.linux-${CARCH}-cpython-$(get_pyver)" make -C docs html
}
check() {
- cd ${srcdir}/${_pyname}-${pkgver}
+ cd ${srcdir}/${_pyname}-${_pkgver}
pytest "build/lib.linux-${CARCH}-cpython-$(get_pyver)" || warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count --remote-data=any
}
package_python-photutils() {
- depends=('python>=3.9' 'python-numpy>=1.22' 'python-astropy>=5.1')
- optdepends=('python-scipy>=1.7.2: To power a variety of features in several modules (strongly recommended)'
- 'python-scikit-image>=0.19: Used in deblend_sources for deblending segmented sources'
- 'python-scikit-learn>=1.0: Used in DBSCANGroup to create star groups'
+ depends=('python>=3.10' 'python-numpy>=1.23' 'python-astropy>=5.1')
+ optdepends=('python-scipy>=1.8: To power a variety of features in several modules (strongly recommended)'
+ 'python-scikit-image>=0.20: Used in deblend_sources for deblending segmented sources'
+ 'python-scikit-learn>=1.1: Used in DBSCANGroup to create star groups'
'python-matplotlib>=3.5: To power a variety of plotting features (e.g. plotting apertures'
'python-gwcs>=0.18: Used in make_gwcs to create a simple celestial gwcs object'
'python-bottleneck: Improves the performance of sigma clipping and other functionality that may require computing statistics on arrays with NaN values'
@@ -81,7 +83,7 @@ package_python-photutils() {
'python-rasterio: Used for converting source segments into polygon objects'
'python-shapley: Used for converting source segments into polygon objects'
'python-photutils-doc: Documentation for python-photutils')
- cd ${srcdir}/${_pyname}-${pkgver}
+ cd ${srcdir}/${_pyname}-${_pkgver}
install -D -m644 LICENSE.rst -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
@@ -91,7 +93,7 @@ package_python-photutils() {
package_python-photutils-doc() {
pkgdesc="Documentation for Python Photutils module"
arch=('any')
- cd ${srcdir}/${_pyname}-${pkgver}/docs/_build
+ cd ${srcdir}/${_pyname}-${_pkgver}/docs/_build
install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" ../../LICENSE.rst
install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"