summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD33
3 files changed, 30 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f6e5a6cb3d6..bd58c7f33232 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = python-plac
- pkgdesc = The smartest command line arguments parser in the world
- pkgver = 1.3.5
+ pkgdesc = parsing the command line the easy way
+ pkgver = 1.4.3
pkgrel = 1
- url = https://pypi.org/project/plac/
+ url = https://github.com/ialbert/plac
arch = any
- license = BSD
+ license = BSD-2-Clause
makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
- source = https://files.pythonhosted.org/packages/source/p/plac/plac-1.3.5.tar.gz
- b2sums = 8c770ea43d94a5fa80fa22f0e1fb6433e7901769315e0ecd9d6889d773e454b428265c3cd43792867dd56757cc6e31dcbda76052b46266878f07e493cf899c14
+ source = python-plac-1.4.3.tar.gz::https://github.com/ialbert/plac/archive/refs/tags/v1.4.3.tar.gz
+ b2sums = 32e2d88bc580c6f886982bd673142e34e2203d3eabdb828d84397e842e4fa00a2bb1e02c73134f58c3a5d8edb83496ccd6a7f7791b6a16c494d44c90dced69b0
pkgname = python-plac
diff --git a/.gitignore b/.gitignore
index d725ba4cf0d2..018a3de08144 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
-*.tar.*
-pkg/
-src/
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index a9e8ab8a3940..3845de9b934f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
-# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Contributor: Philip Goto <philip.goto@gmail.com>
# Contributor: Ryan Gonzalez <rymg19@gmail.com>
-_pkgname=plac
-pkgname=python-${_pkgname}
-pkgver=1.3.5
+pkgname=python-plac
+pkgver=1.4.3
pkgrel=1
-pkgdesc='The smartest command line arguments parser in the world'
+pkgdesc='parsing the command line the easy way'
arch=(any)
-url='https://pypi.org/project/plac/'
-license=(BSD)
-depends=(python)
-makedepends=(python-setuptools)
-source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-b2sums=('8c770ea43d94a5fa80fa22f0e1fb6433e7901769315e0ecd9d6889d773e454b428265c3cd43792867dd56757cc6e31dcbda76052b46266878f07e493cf899c14')
+url="https://github.com/ialbert/plac"
+license=('BSD-2-Clause')
+depends=('python')
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+b2sums=('32e2d88bc580c6f886982bd673142e34e2203d3eabdb828d84397e842e4fa00a2bb1e02c73134f58c3a5d8edb83496ccd6a7f7791b6a16c494d44c90dced69b0')
build() {
- cd "plac-${pkgver}"
- python setup.py build
+ cd "plac-${pkgver}"
+ python -m build --wheel --no-isolation
}
package() {
- cd "plac-${pkgver}"
- python setup.py install --skip-build --root="${pkgdir}" --optimize=1
- install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-plac/LICENSE"
+ cd "plac-${pkgver}"
+ python -m installer --destdir="$pkgdir/" dist/*.whl
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-plac/LICENSE"
}
+
+# vim: set ts=4 sw=4 et: