summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2bc631bc829b..d04ffefc9e43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = python-polib
pkgdesc = A library to manipulate gettext files
pkgver = 1.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://pypi.python.org/pypi/polib
arch = any
license = MIT
makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
source = python-polib-1.2.0.tar.gz::https://pypi.io/packages/source/p/polib/polib-1.2.0.tar.gz
sha256sums = f3ef94aefed6e183e342a8a269ae1fc4742ba193186ad76f175938621dbfc26b
diff --git a/PKGBUILD b/PKGBUILD
index 1cc46eadc67e..cfd9a15c0194 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,23 +5,23 @@ pkgbase=python-polib
pkgname=('python-polib')
_pkgname=polib
pkgver=1.2.0
-pkgrel=1
+pkgrel=2
pkgdesc='A library to manipulate gettext files'
url='https://pypi.python.org/pypi/polib'
arch=('any')
license=('MIT')
depends=('python')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
source=("${pkgbase}-${pkgver}.tar.gz::https://pypi.io/packages/source/p/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
sha256sums=('f3ef94aefed6e183e342a8a269ae1fc4742ba193186ad76f175938621dbfc26b')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --skip-build --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}