summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--Imports-are-absolute-by-default-in-Python3.patch26
-rw-r--r--PKGBUILD18
-rw-r--r--Relative-paths-should-be-allowed.patch84
-rw-r--r--pssh-read-stdin-as-bytes-in-Python-3.patch16
-rw-r--r--pssh-typeerror-str-does-not-support-the-buffer-interface.patch5
-rw-r--r--pssh-valueerror-the-fd-4-must-be-in-non-blocking-mode.patch6
-rw-r--r--python-pssh.changelog7
9 files changed, 14 insertions, 153 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f37b04084770..145921fea9c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pssh
pkgdesc = Parallel versions of the openssh tools ssh, scp, rsync, nuke, slurp
pkgver = 2.3.5
- pkgrel = 11
+ pkgrel = 12
url = https://github.com/lilydjwg/pssh
changelog = python-pssh.changelog
arch = any
@@ -13,8 +13,6 @@ pkgbase = python-pssh
depends = openssh
depends = python
source = https://github.com/lilydjwg/pssh/archive/refs/tags/v2.3.5.tar.gz
- source = pssh-valueerror-the-fd-4-must-be-in-non-blocking-mode.patch
sha256sums = 97277f9d08b512c6a1b6dc5eac9677f34038096bae24484452d326137ba0d080
- sha256sums = 40b01fd5c2aa59542a5d1bf65a41b861733f71305a9799c1d1ca6661f228a891
pkgname = python-pssh
diff --git a/.gitignore b/.gitignore
index 6dd39bbd03b8..cc6d6c23a02f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
pkg/
src/
*.tar
+*.zst
*.[gx]z
diff --git a/Imports-are-absolute-by-default-in-Python3.patch b/Imports-are-absolute-by-default-in-Python3.patch
deleted file mode 100644
index e59fc0a7a641..000000000000
--- a/Imports-are-absolute-by-default-in-Python3.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 8afbefc445059be55dfd20785ee81e4533ae3af1 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Rogut=C4=97s=20Sparnuotos?= <rogutes@googlemail.com>
-Date: Sun, 26 Feb 2012 11:05:48 +0200
-Subject: [PATCH] Imports are absolute by default in Python3.
-
----
- psshlib/cli.py | 3 ++-
- 1 files changed, 2 insertions(+), 1 deletions(-)
-
-diff --git a/psshlib/cli.py b/psshlib/cli.py
-index c14b309..c342cde 100644
---- a/psshlib/cli.py
-+++ b/psshlib/cli.py
-@@ -6,7 +6,8 @@ import os
- import shlex
- import sys
- import textwrap
--import version
-+
-+from psshlib import version
-
- _DEFAULT_PARALLELISM = 32
- _DEFAULT_TIMEOUT = 0 # "infinity" by default
---
-1.7.9.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 44281f8ab8b8..45367481a830 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
-# Maintainer: Boris Momcilovic <boris.momcilovic@gmail.com>
+# Maintainer: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
+# Contributor: Boris Momcilovic <boris.momcilovic@gmail.com>
# Contributor: Jaroslav Lichtblau <svetlemodry@archlinux.org>
# Contributor: Elis Hughes <elishughes@googlemail.com>
# Contributor: Mark Blakeney at bullet-systems dot net
pkgname=python-pssh
pkgver=2.3.5
-pkgrel=11
+pkgrel=12
pkgdesc="Parallel versions of the openssh tools ssh, scp, rsync, nuke, slurp"
arch=('any')
url="https://github.com/lilydjwg/pssh"
@@ -13,17 +14,8 @@ license=('BSD')
depends=('openssh' 'python')
makedepends=('python-build' 'python-installer' 'python-wheel' 'patch')
changelog=$pkgname.changelog
-source=(https://github.com/lilydjwg/pssh/archive/refs/tags/v${pkgver}.tar.gz
- pssh-valueerror-the-fd-4-must-be-in-non-blocking-mode.patch)
-sha256sums=('97277f9d08b512c6a1b6dc5eac9677f34038096bae24484452d326137ba0d080'
- '40b01fd5c2aa59542a5d1bf65a41b861733f71305a9799c1d1ca6661f228a891')
-
-prepare() {
- cd "${srcdir}"/pssh-$pkgver
-
-# fix FS#46571
- patch -Np0 -i ../pssh-valueerror-the-fd-4-must-be-in-non-blocking-mode.patch
-}
+source=(https://github.com/lilydjwg/pssh/archive/refs/tags/v${pkgver}.tar.gz)
+sha256sums=('97277f9d08b512c6a1b6dc5eac9677f34038096bae24484452d326137ba0d080')
build() {
cd "${srcdir}"/pssh-$pkgver
diff --git a/Relative-paths-should-be-allowed.patch b/Relative-paths-should-be-allowed.patch
deleted file mode 100644
index c129a2a7cc3c..000000000000
--- a/Relative-paths-should-be-allowed.patch
+++ /dev/null
@@ -1,84 +0,0 @@
-From 887b49452acfa897e700083fe732f1b24788f1d8 Mon Sep 17 00:00:00 2001
-From: Mark Blakeney <mark.blakeney@bullet-systems.net>
-Date: Tue, 21 May 2019 09:24:56 +1000
-Subject: [PATCH] Relative paths should be allowed
-
-This applies the fix for https://code.google.com/archive/p/parallel-ssh/issues/83.
----
- bin/prsync | 4 ----
- bin/pscp | 6 +-----
- bin/pslurp | 5 +----
- 3 files changed, 2 insertions(+), 13 deletions(-)
-
-diff --git a/bin/prsync b/bin/prsync
-index 84130af..354e225 100755
---- a/bin/prsync
-+++ b/bin/prsync
-@@ -7,7 +7,6 @@
- """Parallel rsync to the set of nodes in hosts.txt.
-
- For each node, we essentially do a rsync -rv -e ssh local user@host:remote.
--Note that remote must be an absolute path.
- """
-
- import os
-@@ -110,9 +109,6 @@ if __name__ == "__main__":
- opts, args = parse_args()
- local = args[0]
- remote = args[1]
-- if not re.match("^/", remote):
-- print("Remote path %s must be an absolute path" % remote)
-- sys.exit(3)
- try:
- hosts = psshutil.read_host_files(opts.host_files,
- default_user=opts.user)
-diff --git a/bin/pscp b/bin/pscp
-index 5b89b70..75bf449 100755
---- a/bin/pscp
-+++ b/bin/pscp
-@@ -7,8 +7,7 @@
- """Parallel scp to the set of nodes in hosts.txt.
-
- For each node, we essentially do a scp [-r] local user@host:remote. This
--program also uses the -q (quiet) and -C (compression) options. Note that
--remote must be an absolute path.
-+program also uses the -q (quiet) and -C (compression) options.
- """
-
- import os
-@@ -92,9 +91,6 @@ if __name__ == "__main__":
- opts, args = parse_args()
- localargs = args[0:-1]
- remote = args[-1]
-- if not re.match("^/", remote):
-- print("Remote path %s must be an absolute path" % remote)
-- sys.exit(3)
- try:
- hosts = psshutil.read_host_files(opts.host_files,
- default_user=opts.user)
-diff --git a/bin/pslurp b/bin/pslurp
-index c7dece6..8a73124 100755
---- a/bin/pslurp
-+++ b/bin/pslurp
-@@ -8,7 +8,7 @@
-
- For each node, we essentially do a scp [-r] user@host:remote
- outdir/<node>/local. This program also uses the -q (quiet) and -C
--(compression) options. Note that remote must be an absolute path.
-+(compression) options.
- """
-
- import os
-@@ -113,9 +113,6 @@ if __name__ == "__main__":
- opts, args = parse_args()
- remote = args[0]
- local = args[1]
-- if not re.match("^/", remote):
-- print("Remote path %s must be an absolute path" % remote)
-- sys.exit(3)
- try:
- hosts = psshutil.read_host_files(opts.host_files,
- default_user=opts.user)
---
-2.21.0
-
diff --git a/pssh-read-stdin-as-bytes-in-Python-3.patch b/pssh-read-stdin-as-bytes-in-Python-3.patch
deleted file mode 100644
index c64d77461cb2..000000000000
--- a/pssh-read-stdin-as-bytes-in-Python-3.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/bin/pssh b/bin/pssh
-index 860bad2..5fe726d 100755
---- a/bin/pssh
-+++ b/bin/pssh
-@@ -65,7 +65,10 @@ def do_pssh(hosts, cmdline, opts):
- if opts.errdir and not os.path.exists(opts.errdir):
- os.makedirs(opts.errdir)
- if opts.send_input:
-- stdin = sys.stdin.read()
-+ if hasattr(sys.stdin, 'buffer'):
-+ stdin = sys.stdin.buffer.read()
-+ else:
-+ stdin = sys.stdin.read()
- else:
- stdin = None
- manager = Manager(opts)
diff --git a/pssh-typeerror-str-does-not-support-the-buffer-interface.patch b/pssh-typeerror-str-does-not-support-the-buffer-interface.patch
deleted file mode 100644
index 9fa81173ebbc..000000000000
--- a/pssh-typeerror-str-does-not-support-the-buffer-interface.patch
+++ /dev/null
@@ -1,5 +0,0 @@
---- psshlib/askpass_server.py.orig 2012-02-02 17:13:09.000000000 +0100
-+++ psshlib/askpass_server.py 2016-01-17 11:43:37.006779012 +0100
-@@ -72 +72 @@
-- bytes_written = conn.send(buffer)
-+ bytes_written = conn.send(buffer.encode())
diff --git a/pssh-valueerror-the-fd-4-must-be-in-non-blocking-mode.patch b/pssh-valueerror-the-fd-4-must-be-in-non-blocking-mode.patch
deleted file mode 100644
index e1fca28b5488..000000000000
--- a/pssh-valueerror-the-fd-4-must-be-in-non-blocking-mode.patch
+++ /dev/null
@@ -1,6 +0,0 @@
---- psshlib/manager.py.orig 2012-02-02 17:13:09.000000000 +0100
-+++ psshlib/manager.py 2016-01-17 11:52:13.764088460 +0100
-@@ -4,0 +5 @@
-+import fcntl
-@@ -211,0 +213 @@
-+ fcntl.fcntl(wakeup_writefd, fcntl.F_SETFL, os.O_NONBLOCK)
diff --git a/python-pssh.changelog b/python-pssh.changelog
index 9acedb4c2691..d187cbe3ca6c 100644
--- a/python-pssh.changelog
+++ b/python-pssh.changelog
@@ -1,3 +1,10 @@
+2023-06-09 Hyacinthe Cartiaux <hyacinthe.cartiaux@uni.lu>
+ * pssh 2.3.5-12 All patches upstreamed, removed from the PKGBUILD
+
+2023-05-29 Boris Momčilović <boris@firstbeatmedia.com>
+ * Update to minor release 2.3.5-11
+ * Upstream repository changed
+
2016-11-21 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* pssh 2.3.1-8 FS#51533 and pssh dropped from [community]