summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD23
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c6e7746dcfea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-pyally
+ pkgdesc = Ally Invest API Wrapper
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = https://pypi.org/project/pyally
+ arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python
+ depends = python-pandas
+ depends = python-pytz
+ depends = python-requests
+ depends = python-requests-oauthlib
+ source = https://files.pythonhosted.org/packages/source/p/pyally/pyally-1.1.2.tar.gz
+ sha256sums = d5dba065ddbf18261b83e29e5fffff731d9b03a4278eb9a9333a17f2d1772d4d
+
+pkgname = python-pyally
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68cda4d50b92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Achmad Fathoni<fathoni.id(at)gmail.com>
+pkgname=python-pyally
+_pkgname=${pkgname:7}
+pkgver=1.1.2
+pkgrel=1
+pkgdesc="Ally Invest API Wrapper"
+arch=('any')
+url="https://pypi.org/project/${_pkgname}"
+license=('MIT')
+makedepends=(python-build python-installer python-wheel)
+depends=(python python-pandas python-pytz python-requests python-requests-oauthlib)
+source=(https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz)
+sha256sums=('d5dba065ddbf18261b83e29e5fffff731d9b03a4278eb9a9333a17f2d1772d4d')
+
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}