summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD16
2 files changed, 19 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7aff907a403c..cf0d58cf30d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,29 @@
pkgbase = python-pydl
pkgdesc = Library of IDL astronomy routines converted to Python
- pkgver = 1.0.0
+ pkgver = 1.0.1
pkgrel = 1
url = http://pydl.readthedocs.io/
arch = any
- license = BSD
+ license = BSD-3-Clause
+ checkdepends = python-pytest-astropy-header
checkdepends = python-pytest-doctestplus
+ checkdepends = python-pytest-remotedata
checkdepends = python-pytest-mock
makedepends = python-setuptools-scm
makedepends = python-wheel
makedepends = python-build
makedepends = python-installer
makedepends = python-sphinx-astropy
+ makedepends = python-matplotlib
makedepends = python-astropy
makedepends = python-scipy
makedepends = graphviz
- source = https://files.pythonhosted.org/packages/source/p/pydl/pydl-1.0.0.tar.gz
- md5sums = 8bf313aeb530669ab6ba364a38b020ab
+ source = https://files.pythonhosted.org/packages/source/p/pydl/pydl-1.0.1.tar.gz
+ md5sums = 5f8942da0d3042a994cea6687f7ca2ba
pkgname = python-pydl
- depends = python-astropy
- depends = python-scipy
+ depends = python-astropy>=5.0
+ depends = python-scipy>=1.3
optdepends = python-matplotlib: all
optdepends = python-pytest-astropy: For testing
optdepends = python-pydl-doc: Documentation for PyDL
diff --git a/PKGBUILD b/PKGBUILD
index 3bd16c514ec8..1f69baac5793 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,30 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
+
pkgbase=python-pydl
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=1.0.0
+pkgver=1.0.1
pkgrel=1
pkgdesc="Library of IDL astronomy routines converted to Python"
arch=('any')
url="http://pydl.readthedocs.io/"
-license=('BSD')
+license=('BSD-3-Clause')
makedepends=('python-setuptools-scm'
'python-wheel'
'python-build'
'python-installer'
'python-sphinx-astropy'
+ 'python-matplotlib'
'python-astropy'
'python-scipy'
'graphviz')
-checkdepends=('python-pytest-doctestplus'
+checkdepends=('python-pytest-astropy-header'
+ 'python-pytest-doctestplus'
+ 'python-pytest-remotedata'
'python-pytest-mock') # astropy scipy already in makedepends
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
#source=("https://files.pythonhosted.org/packages/73/87/397a0d22112f48b794b39613ee3bddd315e64a38b33f24898962c4def5e4/pydl-0.7.0.tar.gz")
-md5sums=('8bf313aeb530669ab6ba364a38b020ab')
+md5sums=('5f8942da0d3042a994cea6687f7ca2ba')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -33,11 +37,11 @@ build() {
check() {
cd ${srcdir}/${_pyname}-${pkgver}
- pytest || warning "Tests failed" # -vv -ra --color=yes -o console_output_style=count
+ pytest --remote-data || warning "Tests failed" # -vv -ra --color=yes -o console_output_style=count
}
package_python-pydl() {
- depends=('python-astropy' 'python-scipy')
+ depends=('python-astropy>=5.0' 'python-scipy>=1.3')
optdepends=('python-matplotlib: all'
'python-pytest-astropy: For testing'
'python-pydl-doc: Documentation for PyDL')