summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..83f29170cf0b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python-pygame_sdl2-git
+ pkgdesc = Reimplementation of portions of the pygame API using SDL2.
+ pkgver = renpy.6.99.0.303.r28.gd5869f1
+ pkgrel = 1
+ url = http://sourceforge.net/projects/brandy/files/brandy/brandy-1.20/brandy-1.20.1.tar.gz/download
+ arch = i686
+ arch = x86_64
+ groups = zlib
+ groups = LGPL
+ license = GPL
+ makedepends = git
+ makedepends = cython
+ depends = python
+ depends = sdl2_mixer
+ depends = sdl2_image
+ depends = sdl2_gfx
+ depends = sdl2_ttf
+ source = git+https://github.com/renpy/pygame_sdl2.git
+ md5sums = SKIP
+
+pkgname = python-pygame_sdl2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a24ce41a71d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jesse Jaara <jesse.jaara@gmail.com>
+
+pkgname=python-pygame_sdl2-git
+pkgver=renpy.6.99.0.303.r28.gd5869f1
+pkgrel=1
+pkgdesc="Reimplementation of portions of the pygame API using SDL2."
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/brandy/files/brandy/brandy-1.20/brandy-1.20.1.tar.gz/download"
+license=('GPL')
+groups=('zlib' 'LGPL')
+depends=('python' 'sdl2_mixer' 'sdl2_image' 'sdl2_gfx' 'sdl2_ttf')
+makedepends=('git' 'cython')
+source=(git+https://github.com/renpy/pygame_sdl2.git)
+md5sums=(SKIP)
+
+pkgver() {
+ cd "pygame_sdl2"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/pygame_sdl2"
+
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/pygame_sdl2"
+
+ python setup.py install --optimize=1 --root="${pkgdir}/"
+}
+
+# vim:set ts=2 sw=2 et: