summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD31
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a1387caf278
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-pyknos
+ pkgdesc = conditional density estimation
+ pkgver = 0.15.2
+ pkgrel = 1
+ url = https://github.com/mackelab/pyknos
+ arch = any
+ license = AGPL3
+ makedepends = python-build
+ makedepends = python-installer
+ depends = python-matplotlib
+ depends = python-numpy
+ depends = tensorboard
+ depends = python-pytorch
+ depends = python-tqdm
+ depends = python-nflows
+ provides = lsbi
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/source/p/pyknos/pyknos-0.15.2.tar.gz
+ sha256sums = ee09ea841858e79ed9f3e104b6654aea676f3403a2f228ef76151e108968caf3
+
+pkgname = python-pyknos
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a6b8c850ccb9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+*.tar.xz
+*.tar.zst
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e13dd75df7e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+pkgname=python-pyknos
+_name=${pkgname#python-}
+pkgver=0.15.2
+pkgrel=1
+pkgdesc="conditional density estimation"
+arch=(any)
+url="https://github.com/mackelab/pyknos"
+license=(AGPL3)
+groups=()
+depends=(python-matplotlib python-numpy tensorboard python-pytorch python-tqdm python-nflows)
+makedepends=(python-build python-installer)
+provides=(lsbi)
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('ee09ea841858e79ed9f3e104b6654aea676f3403a2f228ef76151e108968caf3')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}
+