summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD21
2 files changed, 19 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 763cd6229c73..7c5947107fc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,8 +6,9 @@ pkgbase = python-pylint-plugin-utils
arch = any
license = GPL2
makedepends = python-setuptools
- makedepends = python-pylint
+ makedepends = python-poetry-core
depends = python
+ depends = python-pylint
source = https://github.com/landscapeio/pylint-plugin-utils/archive/refs/tags/0.8.2.tar.gz
sha256sums = e8ff1e1777fee53b0214fb766a6dd15f9c10eb9183a652c888d0e1f453023323
diff --git a/PKGBUILD b/PKGBUILD
index 41b2a557241c..7369c57ad5b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,20 +7,33 @@ pkgdesc="Utilities and helpers for writing Pylint plugins"
arch=('any')
url="https://github.com/landscapeio/pylint-plugin-utils"
license=('GPL2')
-depends=('python')
-makedepends=('python-setuptools' 'python-pylint')
+depends=('python' 'python-pylint')
+makedepends=('python-setuptools' 'python-poetry-core')
#source=("https://pypi.io/packages/source/p/${_pypi_pkgname}/${_pypi_pkgname}-${pkgver}.tar.gz")
source=("https://github.com/landscapeio/pylint-plugin-utils/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('e8ff1e1777fee53b0214fb766a6dd15f9c10eb9183a652c888d0e1f453023323')
build() {
cd "${_pypi_pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
+ #python setup.py build
}
package() {
cd "${_pypi_pkgname}-${pkgver}"
- python setup.py install --prefix="/usr" --root="${pkgdir}" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ #python setup.py install --prefix="/usr" --root="${pkgdir}" --optimize=1
install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
}
+
+check(){
+ cd "${_pypi_pkgname}-${pkgver}"
+
+ # For nosetests
+ #nosetests
+
+ # For pytest
+ pytest
+}
+
# vim:set ts=2 sw=2 et: