summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--posixlibs.patch18
3 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1693f15269c7..2aaf0796cc9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = python-pylsl
pkgdesc = Python interface to the Lab Streaming Layer
- pkgver = 1.13.0
+ pkgver = 1.13.1
pkgrel = 1
url = https://github.com/labstreaminglayer/liblsl-Python
arch = any
license = MIT
depends = liblsl
conflicts = python-pylsl
- source = https://github.com/labstreaminglayer/liblsl-Python/archive/v1.13.0.tar.gz
+ source = https://github.com/labstreaminglayer/liblsl-Python/archive/v1.13.1.tar.gz
source = posixlibs.patch
- sha384sums = adabd2396461667365df4d314875f267787244dce2406e16644555dd4d983f196cfbdccbef00fa4d408a54716c1c3c05
- sha384sums = 7e71482a33178f7d452e0783967ca90dfe83f4dbac07230697a888a156d0af2657697c40d9fd9ec6c504dc6999895793
+ sha384sums = bd66c7b77103c338d5d81d10f03d70724326edec02117445a624f0240c7a04718107b238a728a44d27197cb586b577f9
+ sha384sums = 4fff43c98b8b96714479a3f2fde65eecaa53693bd9b73a8502e939d8f365cfec1b4c6e8c2cdc256b618d03afb520a16a
pkgname = python-pylsl
diff --git a/PKGBUILD b/PKGBUILD
index 4483dec3d9c3..65d5d7c124a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=python-pylsl
pkgname=(python-pylsl python2-pylsl)
_name=${pkgname#python-}
-pkgver=1.13.0
+pkgver=1.13.1
pkgrel=1
pkgdesc='Python interface to the Lab Streaming Layer'
url='https://github.com/labstreaminglayer/liblsl-Python'
@@ -11,10 +11,10 @@ arch=('any')
license=('MIT')
conflicts=($pkgname)
depends=('liblsl')
-source=('https://github.com/labstreaminglayer/liblsl-Python/archive/v1.13.0.tar.gz'
+source=('https://github.com/labstreaminglayer/liblsl-Python/archive/v1.13.1.tar.gz'
'posixlibs.patch')
-sha384sums=('adabd2396461667365df4d314875f267787244dce2406e16644555dd4d983f196cfbdccbef00fa4d408a54716c1c3c05'
- '7e71482a33178f7d452e0783967ca90dfe83f4dbac07230697a888a156d0af2657697c40d9fd9ec6c504dc6999895793')
+sha384sums=('bd66c7b77103c338d5d81d10f03d70724326edec02117445a624f0240c7a04718107b238a728a44d27197cb586b577f9'
+ '4fff43c98b8b96714479a3f2fde65eecaa53693bd9b73a8502e939d8f365cfec1b4c6e8c2cdc256b618d03afb520a16a')
prepare(){
cd "$srcdir/liblsl-Python-${pkgver}"
diff --git a/posixlibs.patch b/posixlibs.patch
index 797014d66a93..6cdb0091f323 100644
--- a/posixlibs.patch
+++ b/posixlibs.patch
@@ -1,6 +1,6 @@
-diff --unified --recursive --text liblsl-Python-1.13.0/MANIFEST.in liblsl-Python-1.13.0.posixlibs/MANIFEST.in
---- liblsl-Python-1.13.0/MANIFEST.in 2018-12-17 09:44:52.000000000 -0600
-+++ liblsl-Python-1.13.0.posixlibs/MANIFEST.in 2019-07-28 22:40:16.586394137 -0500
+diff --unified --recursive --text liblsl-Python-1.13.1/MANIFEST.in liblsl-Python-1.13.1.posixlibs/MANIFEST.in
+--- liblsl-Python-1.13.1/MANIFEST.in 2018-12-17 12:47:57.000000000 -0600
++++ liblsl-Python-1.13.1.posixlibs/MANIFEST.in 2019-07-28 22:48:11.268288919 -0500
@@ -1,6 +1,2 @@
include README.md
include LICENSE
@@ -8,9 +8,9 @@ diff --unified --recursive --text liblsl-Python-1.13.0/MANIFEST.in liblsl-Python
-# If using Python 2.6 or less, then have to include package data, even though
-# it's already declared in setup.py
-include pylsl/liblsl*.*
-diff --unified --recursive --text liblsl-Python-1.13.0/pylsl/pylsl.py liblsl-Python-1.13.0.posixlibs/pylsl/pylsl.py
---- liblsl-Python-1.13.0/pylsl/pylsl.py 2018-12-17 09:44:52.000000000 -0600
-+++ liblsl-Python-1.13.0.posixlibs/pylsl/pylsl.py 2019-07-28 22:40:57.100140914 -0500
+diff --unified --recursive --text liblsl-Python-1.13.1/pylsl/pylsl.py liblsl-Python-1.13.1.posixlibs/pylsl/pylsl.py
+--- liblsl-Python-1.13.1/pylsl/pylsl.py 2018-12-17 12:47:57.000000000 -0600
++++ liblsl-Python-1.13.1.posixlibs/pylsl/pylsl.py 2019-07-28 22:47:58.491471938 -0500
@@ -1192,7 +1192,7 @@
raise RuntimeError("unrecognized operating system:", os_name)
libpath = os.path.join(os.path.dirname(__file__), 'lib', libname)
@@ -20,9 +20,9 @@ diff --unified --recursive --text liblsl-Python-1.13.0/pylsl/pylsl.py liblsl-Pyt
if not libpath:
raise RuntimeError("library " + libname + " was not found - make sure "
"that it is on the search path (e.g., in the same "
-diff --unified --recursive --text liblsl-Python-1.13.0/setup.py liblsl-Python-1.13.0.posixlibs/setup.py
---- liblsl-Python-1.13.0/setup.py 2018-12-17 09:44:52.000000000 -0600
-+++ liblsl-Python-1.13.0.posixlibs/setup.py 2019-07-28 22:41:32.070503361 -0500
+diff --unified --recursive --text liblsl-Python-1.13.1/setup.py liblsl-Python-1.13.1.posixlibs/setup.py
+--- liblsl-Python-1.13.1/setup.py 2018-12-17 12:47:57.000000000 -0600
++++ liblsl-Python-1.13.1.posixlibs/setup.py 2019-07-28 22:48:32.188536008 -0500
@@ -104,16 +104,6 @@
# $ pip install -e .[dev,test]
# extras_require={},