summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..083c27b55890
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pymarshal
+ pkgdesc = Pythonic implementation of Golang's (un)marshalling of structs to/from various data serialization formats
+ pkgver = 2.2.0
+ pkgrel = 1
+ url = https://github.com/stargateaudio/pymarshal
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = python-pytest-runner
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/p/pymarshal/pymarshal-2.2.0.tar.gz
+ sha256sums = 2f2377170261be43233375c9c2726fc9b8f9daacc75eb18458d2e1c6cd8578a2
+
+pkgname = python-pymarshal
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd2bba091cba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: kiasoc5 <kiasoc5 at tutanota dot com>
+pkgname='python-pymarshal'
+_module=${pkgname#python-}
+pkgver='2.2.0'
+pkgrel=1
+pkgdesc="Pythonic implementation of Golang's (un)marshalling of structs to/from various data serialization formats"
+url="https://github.com/stargateaudio/pymarshal"
+depends=('python')
+makedepends=('python-setuptools' 'python-pytest-runner')
+license=('BSD')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('2f2377170261be43233375c9c2726fc9b8f9daacc75eb18458d2e1c6cd8578a2')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}