summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ca85e129fe3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pymultihash
+ pkgdesc = Python implementation of the multihash specification
+ pkgver = 0.8.2
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/pymultihash
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-setuptools
+ source = https://pypi.io/packages/source/p/pymultihash/pymultihash-0.8.2.tar.gz
+ sha256sums = 49c75a1ae9ecc6d22d259064d4597b3685da3f0258f4ded632e03a3a79af215b
+
+pkgname = python-pymultihash
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1aee993719d9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.zst
+*.tar.gz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9da010ff71c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: redfish <redfish@galactica.pw>
+
+pkgname=python-pymultihash
+_name=pymultihash
+pkgver=0.8.2
+pkgrel=1
+pkgdesc="Python implementation of the multihash specification"
+arch=('any')
+url="https://pypi.python.org/pypi/pymultihash" license=('MIT')
+depends=('python'
+ 'python-setuptools'
+ )
+checkdepends=()
+source=("https://pypi.io/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ chmod -R a+r "$pkgdir" # upstream installer messes up permissions
+}
+
+sha256sums=('49c75a1ae9ecc6d22d259064d4597b3685da3f0258f4ded632e03a3a79af215b')