summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-x.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 4 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b33e333b1028..509a0d1015e2 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = python-pynput
pkgdesc = Python library to monitor and control user input devices
pkgver = 1.7.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/moses-palmer/pynput
arch = any
license = LGPL3
makedepends = python-setuptools-lint
+ makedepends = python-sphinx
depends = python-xlib
depends = python-six
depends = python-evdev
- optdepends = python-sphinx: build online documentation
source = https://pypi.org/packages/source/p/pynput/pynput-1.7.3.tar.gz
source = python-pynput.patch
sha256sums = 4e50b1a0ab86847e87e58f6d1993688b9a44f9f4c88d4712315ea8eb552ef828
diff --git a/PKGBUILD b/PKGBUILD
index c51dfae63f28..bd673e369654 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,18 @@
pkgname=python-pynput
_name=${pkgname#python-}
pkgver=1.7.3
-pkgrel=2
+pkgrel=3
pkgdesc="Python library to monitor and control user input devices"
arch=('any')
url="https://github.com/moses-palmer/pynput"
license=('LGPL3')
depends=('python-xlib' 'python-six' 'python-evdev')
-makedepends=('python-setuptools-lint')
-optdepends=('python-sphinx: build online documentation')
+makedepends=('python-setuptools-lint' 'python-sphinx')
source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz"
"$pkgname.patch")
sha256sums=('4e50b1a0ab86847e87e58f6d1993688b9a44f9f4c88d4712315ea8eb552ef828'
'b2e10f5baf1501e8365b1a95fd756cde5a8510107d89557ab764a47c3ef47226')
-prepare() {
- cd "$_name-$pkgver"
- patch -Np1 -i "$srcdir/python-pynput.patch"
-}
-
build() {
cd "$_name-$pkgver"
python setup.py build