summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e7e20a60b702
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-pyqtgraph-git
+ pkgdesc = Scientific Graphics and GUI Library for Python
+ pkgver = 0.9.10.r953.g1036edf
+ pkgrel = 1
+ url = https://github.com/pyqtgraph/pyqtgraph
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python
+ depends = python-pyqt5
+ depends = python-numpy
+ optdepends = python-opengl
+ provides = python-pyqtgraph
+ conflicts = python-pyqtgraph
+ source = python-pyqtgraph-git::git+https://github.com/pyqtgraph/pyqtgraph.git
+ sha256sums = SKIP
+
+pkgname = python-pyqtgraph-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..709d6e181a4c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Kenneth Lyons (ixjlyons) <ixjlyons@gmail.com>
+
+pkgname=python-pyqtgraph-git
+pkgver=0.9.10.r953.g1036edf
+pkgrel=1
+pkgdesc='Scientific Graphics and GUI Library for Python'
+arch=('any')
+url='https://github.com/pyqtgraph/pyqtgraph'
+license=('MIT')
+depends=('python' 'python-pyqt5' 'python-numpy')
+optdepends=('python-opengl')
+makedepends=('git')
+provides=('python-pyqtgraph')
+conflicts=('python-pyqtgraph')
+source=(${pkgname}::'git+https://github.com/pyqtgraph/pyqtgraph.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "%s.r%s.g%s" "$(grep __version__ pyqtgraph/__init__.py | head -1 | cut -d"'" -f2)" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${pkgname}"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize 1
+}