summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD28
2 files changed, 21 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52a862585936..a7f781565c2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
pkgbase = python-pyrdfa3
pkgdesc = Python distiller/parser library
- pkgver = 3.5.2
+ pkgver = 3.5.3
pkgrel = 1
url = https://github.com/RDFLib/pyrdfa3
arch = any
license = custom
- makedepends = python-setuptools
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python-rdflib
depends = python-html5lib
depends = python-simplejson
depends = python-isodate
- source = python-pyrdfa3-3.5.2.tar.gz::https://github.com/RDFLib/pyrdfa3/archive/3.5.2.tar.gz
- sha256sums = 2cf88994c9726eae043d24c2b6945ec2d0bf5c417e29dfd86cb5170884015905
+ source = https://files.pythonhosted.org/packages/py3/p/pyRdfa3/pyRdfa3-3.5.3-py3-none-any.whl
+ source = python-pyrdfa3.license::https://raw.githubusercontent.com/RDFLib/pyrdfa3/master/LICENSE
+ sha256sums = 4da7ed49e8f524b573ed67e4f7bc7f403bff3be00546d7438fe263c924a91ccf
+ sha256sums = 18e8c2a924d44bdfdce3055db70bd4de7fad7f1d60df29458755a64bcb04766f
pkgname = python-pyrdfa3
diff --git a/PKGBUILD b/PKGBUILD
index cf2ebac683ed..090f82f5efcd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
-# Maintainer: Yigit Sever <yigit at yigitsever dot com>
+# Maintainer: Lucki <https://aur.archlinux.org/account/Lucki>
+# Contributor: Yigit Sever <yigit at yigitsever dot com>
+# shellcheck shell=bash
+# shellcheck disable=2034,2154
+
pkgname=python-pyrdfa3
-_pkgname=pyrdfa3
-pkgver=3.5.2
+_name=pyRdfa3
+pkgver=3.5.3
pkgrel=1
pkgdesc="Python distiller/parser library"
arch=('any')
url="https://github.com/RDFLib/pyrdfa3"
license=('custom')
depends=('python-rdflib' 'python-html5lib' 'python-simplejson' 'python-isodate')
-makedepends=('python-setuptools')
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('2cf88994c9726eae043d24c2b6945ec2d0bf5c417e29dfd86cb5170884015905')
-
-build() {
- cd "${_pkgname}-${pkgver}"
- python setup.py build
-}
+makedepends=('python-installer' 'python-wheel')
+source=("https://files.pythonhosted.org/packages/py3/${_name::1}/$_name/${_name//-/_}-$pkgver-py3-none-any.whl"
+ "$pkgname.license::https://raw.githubusercontent.com/RDFLib/pyrdfa3/master/LICENSE")
+sha256sums=('4da7ed49e8f524b573ed67e4f7bc7f403bff3be00546d7438fe263c924a91ccf'
+ '18e8c2a924d44bdfdce3055db70bd4de7fad7f1d60df29458755a64bcb04766f')
package() {
- cd "${_pkgname}-${pkgver}"
- python setup.py install --root="$pkgdir" --optimize=1
- install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+ python -m installer --destdir="$pkgdir" "pyRdfa3-3.5.3-py3-none-any.whl"
+ install -Dm644 "$pkgname.license" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}