summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD43
2 files changed, 23 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e12e1aea5269..4823d136cc66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pystache-git
pkgdesc = The mustache template engine written in python
pkgver = 0.5.4.r3.17a5dfd
- pkgrel = 5
+ pkgrel = 6
epoch = 1
url = https://github.com/defunkt/pystache
changelog = history
@@ -12,8 +12,7 @@ pkgbase = python-pystache-git
depends = python
provides = python-pystache
conflicts = python-pystache
- source = git+https://github.com/defunkt/pystache#branch=master
+ source = git+https://github.com/defunkt/pystache.git#branch=master
sha256sums = SKIP
pkgname = python-pystache-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 1d13bc78b1b8..5e625751460a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,47 +9,46 @@ _name=pystache
epoch=1
pkgver() { git -C "$_name" describe --long | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'; }
pkgver=0.5.4.r3.17a5dfd
-pkgrel=5
+pkgrel=6
-pkgdesc="The mustache template engine written in python"
+pkgdesc='The mustache template engine written in python'
arch=('x86_64')
url="https://github.com/defunkt/$_name"
license=('MIT')
-provides=('python-pystache')
-conflicts=('python-pystache')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
-depends=('python')
makedepends=('git' 'python-setuptools')
+depends=('python')
changelog=history
-source=("git+$url#branch=master")
+source=("git+$url.git#branch=master")
sha256sums=('SKIP')
build() {
- cd "$_name"
- python setup.py build
+ cd "$_name"
+ python setup.py build
}
check() {
- # This package uses 2to3 to convert itself to Python 3 on the fly
- # So we need to jump through some hoops here
- rm -rf test_dir
- mkdir test_dir
- cd "$_name"
- python setup.py install --root=../test_dir
- _py3ver="$(python -V | sed 's/Python \(3\.[0-9]\+\).*/\1/')"
- PYTHONPATH="../test_dir/usr/lib/python$_py3ver/site-packages/" \
- ../test_dir/usr/bin/pystache-test .
+ # This package uses 2to3 to convert itself to Python 3 on the fly
+ # So we need to jump through some hoops here
+ rm -rf test_dir
+ mkdir test_dir
+ cd "$_name"
+ python setup.py install --root=../test_dir
+ _py3ver="$(python -V | sed 's/Python \(3\.[0-9]\+\).*/\1/')"
+ PYTHONPATH="../test_dir/usr/lib/python$_py3ver/site-packages/" "../test_dir/usr/bin/$_name-test" .
}
package() {
- cd "$_name"
- PYTHONHASHSEED=0 python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 LICENSE -t"$pkgdir/usr/share/licenses/$_name/"
- install -Dm644 {README,HISTORY}.md setup_description.rst -t"$pkgdir/usr/share/doc/$_name/"
+ cd "$_name"
+ PYTHONHASHSEED=0 python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE -t"$pkgdir/usr/share/licenses/$_name/"
+ install -Dm644 {README,HISTORY}.md setup_description.rst -t"$pkgdir/usr/share/doc/$_name/"
}
-# vim: sw=4 ts=4 noet ft=PKGBUILD:
+# vim: sw=2 ts=2 et ft=PKGBUILD: