summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore20
-rw-r--r--LICENSE19
-rw-r--r--PKGBUILD41
4 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66d9c076e2ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-pytest-env
+ pkgdesc = py.test plugin that allows you to add environment variables.
+ pkgver = 0.6.2
+ pkgrel = 1
+ url = https://github.com/MobileDynasty/pytest-env
+ arch = any
+ license = MIT
+ makedepends = python-pytest
+ makedepends = python2-pytest
+ source = https://pypi.org/packages/source/p/pytest-env/pytest-env-0.6.2.tar.gz
+ source = https://raw.githubusercontent.com/MobileDynasty/pytest-env/master/LICENSE
+ sha256sums = 7e94956aef7f2764f3c147d216ce066bf6c42948bb9e293169b1b1c880a580c2
+ sha256sums = 62b9b932cf5effd097de675f6604f05dc1fa57553ad5e25381563c0cd9a922b4
+
+pkgname = python-pytest-env
+ depends = python-pytest
+
+pkgname = python2-pytest-env
+ depends = python2-pytest
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1aace9926737
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,20 @@
+# ignore everything ...
+*
+
+# ... except itself
+!.gitignore
+
+# ... except changes in package
+!PKGBUILD
+!.SRCINFO
+
+# ... except possible source files
+!*.patch
+!*.diff
+!*.desktop
+!*.png
+!LICENSE
+
+# ... except files from PKGBUILD fields
+!*.changelog
+!*.install
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..7aa3caf0a10b
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,19 @@
+The MIT License (MIT)
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c167ce0ad80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
+_name=pytest-env
+pkgname=('python-pytest-env' 'python2-pytest-env')
+pkgbase=python-$_name
+pkgver=0.6.2
+pkgrel=1
+pkgdesc="py.test plugin that allows you to add environment variables."
+arch=(any)
+url="https://github.com/MobileDynasty/pytest-env"
+license=('MIT')
+makedepends=(python-pytest python2-pytest) # setuptools included
+source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz"
+ 'https://raw.githubusercontent.com/MobileDynasty/pytest-env/master/LICENSE')
+sha256sums=('7e94956aef7f2764f3c147d216ce066bf6c42948bb9e293169b1b1c880a580c2'
+ '62b9b932cf5effd097de675f6604f05dc1fa57553ad5e25381563c0cd9a922b4')
+
+prepare() {
+ cp -a $_name-$pkgver{,-py2}
+}
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
+
+ cd "$srcdir/$_name-$pkgver-py2"
+ python2 setup.py build
+}
+
+package_python-pytest-env() {
+ depends=(python-pytest)
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -D -m644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+package_python2-pytest-env() {
+ depends=(python2-pytest)
+ cd "$srcdir/$_name-$pkgver-py2"
+ python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -D -m644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}